hdu1195Open the Lock

10 篇文章 0 订阅

Open the Lock

Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9.
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.

Now your task is to use minimal steps to open the lock.

Note: The leftmost digit is not the neighbor of the rightmost digit.

Input

The input file begins with an integer T, indicating the number of test cases.

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.

Output

For each test case, print the minimal steps in one line.

Sample Input

2

1234

2144

 

1111

9999

Sample Output

2

4

 

普通的BFS,将已经访问过的状态标记下即可

#include<algorithm>

#include<cstdio>

#include<cstring>

#include<iostream>

#include<queue>

using namespace std;

struct node

{

    int num[4];

    int time;

}first,last;

int mark[11][11][11][11];//用四维数组标记是否使用过

void bfs()

{

    int i;

    node st,ed;

    queue<node>que;

    st=first;

    st.time=0;

    mark[st.num[0]][st.num[1]][st.num[2]][st.num[3]]=1;

    que.push(st);

    while(!que.empty())

    {

        st=que.front();

        que.pop();

        if(st.num[0]==last.num[0]&&st.num[1]==last.num[1]&&st.num[2]==last.num[2]&&st.num[3]==last.num[3])

        {

            printf("%d\n",st.time);

            return;

        }

        for(i=0;i<4;i++)//+1

        {

            ed=st;

            ed.num[i]++;

            if(ed.num[i]==10)

                ed.num[i]=1;

            if(!mark[ed.num[0]][ed.num[1]][ed.num[2]][ed.num[3]])

            {

                mark[ed.num[0]][ed.num[1]][ed.num[2]][ed.num[3]]=1;

                ed.time++;

                que.push(ed);

            }

        }

        for(i=0;i<4;i++)//-1

        {

            ed=st;

            ed.num[i]--;

            if(ed.num[i]==0)

                ed.num[i]=9;

            if(!mark[ed.num[0]][ed.num[1]][ed.num[2]][ed.num[3]])

            {

                mark[ed.num[0]][ed.num[1]][ed.num[2]][ed.num[3]]=1;

                ed.time++;

                que.push(ed);

            }

        }

        for(i=0;i<3;i++)//交换 注意别超范围

        {

            ed=st;

            ed.num[i]=st.num[i+1];

            ed.num[i+1]=st.num[i];

            if(!mark[ed.num[0]][ed.num[1]][ed.num[2]][ed.num[3]])

            {

                mark[ed.num[0]][ed.num[1]][ed.num[2]][ed.num[3]]=1;

                ed.time++;

                que.push(ed);

            }

        }

    }

}

int main()

{

    char s1[10],s2[10];

    int T;

    cin>>T;

    while(T--)

    {

        scanf("%s%s",s1,s2);

        for(int i=0;i<4;i++)

        {

            first.num[i]=s1[i]-'0';

            last.num[i]=s2[i]-'0';

        }

        memset(mark,0,sizeof(mark));

        bfs();

    }

    return 0;

}

 

给你四个数字,每次可以将其中任何一个数字 +1 或者 -1 ; 1的时候-1 等于9  ;9的时候+1 等于1;  问最少需要变换几次,才可以变到目标序列。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值