HDU-1195 Open the Lock

Open the Lock

Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9.
Each time, you can add or minus 1 to any digit. When add 1 to ‘9’, the digit will change to be ‘1’ and when minus 1 to ‘1’, the digit will change to be ‘9’. You can also exchange the digit with its neighbor. Each action will take one step.
Now your task is to use minimal steps to open the lock.
Note: The leftmost digit is not the neighbor of the rightmost digit.

Input
The input file begins with an integer T, indicating the number of test cases.
Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.

Output
For each test case, print the minimal steps in one line.

Sample Input
2
1234
2144

1111
9999

Sample Output
2
4

这是一道简单的bfs入门题。题设每样例给出两行数据,第一行代表密码锁初始显示数字,第二行代表正确密码。每次可对某一数字进行加一或减一操作(当然需注意‘1’与‘9’)或与邻位交换。问找到正确密码的最少步数。
可利用广度优先搜索的思想(bfs)去思考,将每种情况都考虑并记录下来(利用队列,数组),对每组数据的四个数进行加一,减一,邻位交换共十一种可能产生的数据依次压入队列(可能会产生已出现的数据,利用数组标记判断,出现过则不再压入)。然后从队列中不断取出数据重复以上操作,直到找到密码。

附代码:

#include <iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue> 
using namespace std; 
struct node {
    int a[4];
    int step; 
}; 
char s1[5],s2[5]; 
bool visit[10][10][10][10];//标记 
int f[4]; 
int  bfs() {
node now,next;
for(int i=0; i<4; i++)
{
    now.a[i]=s1[i]-'0';
    f[i]=s2[i]-'0';
}
now.step=0;
queue<node>q;//创建队列
q.push(now);
visit[now.a[0]][now.a[1]][now.a[2]][now.a[3]]=true;
bool look;
while(!q.empty())
{
        now=q.front();
        q.pop();
        look=true;
        for(int i=0; i<4; i++)
        {
            if(now.a[i]!=f[i])
            {
                look=false;
                break;
            }
        }
        if(look)
        {
            return now.step;
        }
        for(int i=0; i<4; i++)//加一操作
        {
            next=now;
            if(next.a[i]==9)
                next.a[i]=1;
            else
                next.a[i]+=1;
            next.step=now.step+1;
            if(!visit[next.a[0]][next.a[1]][next.a[2]][next.a[3]])
            {
                q.push(next);
                visit[next.a[0]][next.a[1]][next.a[2]][next.a[3]]=true;
            }
        }
        for(int i=0; i<4; i++)//减一操作
        {
            next=now;
            if(next.a[i]==1)
                next.a[i]=9;
            else
                next.a[i]-=1;
            next.step=now.step+1;
            if(!visit[next.a[0]][next.a[1]][next.a[2]][next.a[3]])
            {
                q.push(next);
                visit[next.a[0]][next.a[1]][next.a[2]][next.a[3]]=true;
            }
        }
        for(int i=0; i<3; i++)//邻位交换
        {
            next=now;
            int r=next.a[i];
            next.a[i]=next.a[i+1];
            next.a[i+1]=r;
            next.step=now.step+1;
            if(!visit[next.a[0]][next.a[1]][next.a[2]][next.a[3]])
            {
                q.push(next);
                visit[next.a[0]][next.a[1]][next.a[2]][next.a[3]]=true;
            }
        }
    }
    return -1; 
} 
int main() 
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(visit,false,sizeof(visit));
        cin>>s1>>s2;
        cout<<bfs()<<endl;
    }
    return 0; 
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值