poj 2139Six Degrees of Cowvin Bacon

Six Degrees of Cowvin Bacon
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5273 Accepted: 2484

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other.  If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow).  This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie.  The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]

Source

 
题意:给你N头牛,共M部电影,在同一部电影里的牛距离是1,如果2头在不同电影里的牛都和某一头牛在各自的电影里,那么这2头牛,距离是2,以此类推,(一头牛可以在不同的电影里)
#include<stdio.h>
#define N 400
int p[N][N];
int f[N];
int n,m;
int min(int x,int y)
{
	return x>y?y:x;
}
void Floyd(void)
{
	int i,j,k;
	for(k=0;k<n;k++)
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				p[i][j]=min(p[i][j],p[i][k]+p[k][j]);
}
int main(void)
{
	int i,j,ans=0x3f3f3f3f,t,sum;
	scanf("%d%d",&n,&m);
	memset(p,0x3f,sizeof(p));
	for(i=0;i<n;i++)
		p[i][i]=0;
    while(m--)
	{
		scanf("%d",&t);
		for(i=0;i<t;i++)
		{
			scanf("%d",&f[i]);
			f[i]--;
		}
		for(i=0;i<t;i++)
			for(j=i+1;j<t;j++)
			{
				p[f[j]][f[i]]=1;
				p[f[i]][f[j]]=1;
			}
        
	}
	Floyd();
    for(i=0;i<n;i++)
	{
		sum=0;
		for(j=0;j<n;j++)
			sum+=p[i][j];
		if(sum<ans)
			ans=sum;
	}
	printf("%d\n",(100*ans)/(n-1));
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值