PAT 1082. Read Number in Chinese (25)

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:
yi Shi Wan ling ba Bai

思路:注意0的读法

 
#include <stdio.h>
#include <iostream>
#include <string>
#include <vector>
using namespace std;
int n;
string list1[10] = {"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
string list2[10] = {"0","Shi","Bai","Qian","Wan","Shi","Bai","Qian","Yi","0"};
vector<string> res;
int main()
{
	while(scanf("%d", &n) != EOF)
	{
		res.clear();
		int list[10];
		int length = 0;
		if(n == 0)
		{
			printf("ling\n");
			continue;
		}
		if(n < 0)
		{
			printf("Fu ");
			n = -n;
		}
		while(n > 0)
		{
			list[length] = n % 10;
			n = n / 10;
			length++;
		}
		int e = 0;
		while(list[e] == 0)
		{
			e++;
		}
		if(e == 8)
		{
			printf("%d Yi\n", list[8]);
			continue;
		}
		if(e > 4)
		{
			res.push_back("Wan");
		}
		for(int i = e; i < length; i++)
		{
			if(i == 0)
			{
				res.push_back(list1[list[i]]);
			}
			else
			{
				if(list[i] != 0 || i == 4 || i == 8)
				{
					res.push_back(list2[i]);
				}
				res.push_back(list1[list[i]]);
			}
		}
		int cnt = 0;
		for(int i = res.size() - 1; i >= 0; i--)
		{
			if(i != res.size() - 1)
			{
				printf(" ");
			}
			cnt = 0;
			while(i >= 0 && res[i].compare("ling") == 0)
			{
				i--;
				cnt++;
			}
			if(cnt == 0)
			{
				cout << res[i];
			}
			else if(cnt < 4)
			{
				if(res[i].compare("Wan") != 0)
				{
					printf("ling");
				if(i != res.size() - 1)
				{
					printf(" ");
				}
				}
				cout << res[i];
			}
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值