hdu 3665

题目链接
http://acm.hdu.edu.cn/showproblem.php?pid=3665

Seaside

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1504 Accepted Submission(s): 1087

Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that the distance between the i-th town and the SMi town is LMi.

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.

Sample Input
5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1

Sample Output
2

题意让你求从0到某一个海边村庄的最短路,用floyd求即可。

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define maxn 0x7fffffff
using namespace std;
long long d[15][15];
int sea[15];
int v;
void floyd()
{
    for(int k=0;k<v;k++)
    {
        for(int i=0;i<v;i++)
        {
            for(int j=0;j<v;j++)
            {
                d[i][j]=min(d[i][j],d[i][k]+d[k][j]);
            }
        }
    }
}
int main (void)
{
    //int r=maxn;
    //printf("maxn=%d\n",r);    
   while(cin>>v){
   memset(sea,0,sizeof(sea));
   for(int i=0;i<v;i++)
   {
        for(int j=0;j<v;j++)
        {
            d[i][j]=maxn;
        }
        d[i][i]=0;
   }
   int a,b;
   int c,le;
   for(int i=0;i<v;i++)
   {
        scanf("%d %d",&a,&b);
        sea[i]=b;
        for(int j=0;j<a;j++)
        {
            scanf("%d %d",&c,&le);
            d[i][c]=le;
        }
   }
   floyd();
   long long ans=maxn;
   for(int i=0;i<v;i++)
   {
    //   floyd();
       if(sea[i]&&d[0][i]<ans)
       {
        ans=d[0][i];
       //   printf("%d___\n",ans);
       }
   }
   printf("%lld\n",ans);
    }
   return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值