【POJ2533】Longest Ordered Subsequence(LIS-最长上升子序列/DP)

Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题目大意:输入一个N代表有一个长度为N的序列,然后找出从小到大(升序)顺序的最长的序列的长度。
如 1 7 3 5 9 4 8 的最长序列是 1 3 5 9有4个单位长度。
可以看出,用dp[]记录到达那的最长序列的话,dp[1]=1。从第二个数开始,如果第二个数大于第一个数num[2]>num[1]那么dp[2]=dp[1]+1否则dp[2]=dp[1]
#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e3+5;

int num[maxn];
int dp[maxn];
int n;
int temp;

int main(){
    while(~scanf("%d",&n)){
        for( int i=1 ; i<=n ; i++ ){
            scanf("%d",&num[i]);
        }
        dp[1]=1;
        for( int i=2 ; i<=n ; i++ ){
            temp = 0;
            for( int j=1 ; j<i ; j++ ){
                if(num[i]>num[j]){
                    if(temp<dp[j]){
                        temp = dp[j]; 
                    }
                }
            }
            dp[i] = temp + 1;
        }
        sort(dp+1,dp+n+1);
        printf("%d\n",dp[n]);
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值