Longest Ordered Subsequence -----最长上升子序列

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 


Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output

4

题意:求最长的递增的序列的长度。

思路:1.动态规划, 最长上升子序列的长度。状态转移方程:dp【i】表示前i项的最长上升子序列的长度。

则dp[i]=max(dp[j])+1; ( 0<j<i且 a[i]>a[ j ])   ; 即dp【i】=dp【0~i】满足(a【i】>a【j】)的最大值+1;

2.在第i个的状态,已知0~(i-1)的最长上升子序列的长度,则第i个只需加入到最恰当的子序列,最恰当的子序列即是

第i个比该子序列的当前最大值大(a【i】(i)>a【j】(当前))  且   

该子序列是满足前一个条件的子序列长度最大值(max dp【j】)。

3.在第i+1个的状态,如

题:    5

        1 3 7 5 6 

i=0时,dp[0]=1,最长上升自序列为1

i=1时,dp[1]=dp[0]+1=2,最长上升自序列为1 3

i=2时,dp[2]=dp[1]+1=3,最长上升自序列为1,3,7;

i=3时,dp【3】=dp【1】+1=3,最长上升自序列为1,3,5(该情况没有用i=2)

i=4时,dp[4]=dp[3]+1=4,最长上升自序列为1,3,5,6

感想(随便写写):动态规划试用条件,当前状态只需在前一状态答案已知的情况下进行简单运算。F(i-1)-->F(i);  即可反推之前状态。


AC代码:

# include <iostream>
# include <cstdio>
using namespace std;


int main ()
{
int n;
while (scanf("%d",&n)!=EOF)
{
int a[n];
for (int i=0;i<n;i++)
scanf("%d",&a[i]);
int dp[n];
dp[0]=1;
for (int i=1;i<n;i++)
{
int mx=0;
for (int j=0;j<=(i-1);j++)
{
if ((a[j]<a[i])&&(dp[j]>mx))
mx=dp[j];
}
dp[i]=mx+1;
}
int mi=0;
for (int i=0;i<n;i++) 
if (dp[i]>mi) mi=dp[i];
printf("%d\n",mi);
}
return 0;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值