经典DP水题A

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4



题意:给一串数字,输出从左往右由小到大的最大长度,即 1 7 3 5 9 4 8,最长为1 3 5 8 或者1 3 4 8等等,长度为4.

思路:DP,从左往右遍历一遍,更新比它小的数,统计此刻长度。




AC java 代码:

import java.util.Scanner;
//3812 KB 1563 ms
public class sdupractice0724DPA {


public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int n = scan.nextInt();
int[][] arr = new int[n][2];
for (int i = 0; i < n; i++) {
arr[i][0] = scan.nextInt();
arr[i][1] = 1;
}
for (int i = 1; i < n; i++) {
int count = 0;
for (int j = 0; j < i; j++) {
if (arr[i][0] > arr[j][0] && arr[j][1] > count) {
count = arr[j][1];
}
}
arr[i][1] += count;
}
int max = 0;
for (int i = 0; i < n; i++) {
if (arr[i][1] > max)
max = arr[i][1];
}
System.out.println(max);
}


}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值