Step5.2.3 hdu 1800Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 142 AcceptedSubmission(s): 75

 

Problem Description

 

 

In the year 8888, the Earth is ruled by thePPF Empire . As the population growing , PPF needs to find more land for thenewborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Herethe problem comes! How can the soldiers reach the Mars ? PPF convokes hissoldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shutup ! Do I have to remind you that there isn’t any road to the Mars from here!”PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although wehaven’t got wings ,I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’stime to learn to fly on a broomstick ! we assume that one soldier has one levelnumber indicating his degree. The soldier who has a higher level could teachthe lower , that is to say the former’s level > the latter’s . But the lowercan’t teach the higher. One soldier can have only one teacher at most ,certainly , having no teacher is also legal. Similarly one soldier can haveonly one student at most while having no student is also possible. Teacher canteach his student on the same broomstick .Certainly , all the soldier must havepracticed on the broomstick before they fly to the Mars! Magic broomstick isexpensive !So , can you help PPF to calculate the minimum number of thebroomstick needed .

For example :

There are 5 soldiers (A B C D E)with levelnumbers : 2 4 5 6 4;

One method :

C could teach B; B could teach A; So , A BC are eligible to study on the same broomstick.

D could teach E;So D E are eligible tostudy on the same broomstick;

Using this method , we need 2 broomsticks.

Another method:

D could teach A; So A D are eligible tostudy on the same broomstick.

C could teach B; So B C are eligible tostudy on the same broomstick.

E with no teacher or student are eligibleto study on one broomstick.

Using the method ,we need 3 broomsticks.

……

 

After checking up all possible method, wefound that 2 is the minimum number of broomsticks needed.

 

 

Input

Input file contains multiple test cases.

In a test case,the first line contains asingle positive number N indicating the number of soldiers.(0<=N<=3000)

Next N lines :There is only one nonnegativeinteger on each line , indicating the level number for each soldier.( less than30 digits);

 

 

Output

For each case, output the minimum number ofbroomsticks on a single line.

 

 

Sample Input

4

10

20

30

04

5

2

3

4

3

4

 

 

Sample Output

1

2

 

 

Author

PPF@JLU

 

 

Recommend

lcy

 

 

Statistic|Submit|Back

题解:

找到一系列数中,相等数最多的个数。不能用map会超时,用scanf可以读取带前缀0的数据。所以这道题就是scanf+sort。

源代码:

#include <iostream>

#include <math.h>

#include <algorithm>

#include <stdio.h>

#include <string>

#include <map>

 

using namespace std;

 

int main()

{

   intn;

   intnum[5000];

   while(scanf("%d", &n) != EOF)

   {

     intmx = 1;

     for(int i = 0;i < n;i++)

        scanf("%d",&num[i]);

     sort(num,num+n);

     intcount = 1;

     for(int i = 0;i < n-1;i++)

     {

        if(num[i]== num[i+1])

        {

          count ++;

          if(count> mx)

             mx = count;

        }

        else        

          count = 1;

     }

     printf("%d\n",mx);

   }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值