UVA10340 POJ1936 ZOJ1970 All in All【字符串匹配】

509 篇文章 6 订阅
232 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 33318 Accepted: 13901

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.  

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.  

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source



问题链接UVA10340 POJ1936 ZOJ1970 All in All

题意简述:输入两个字符串s和t,看s是否是t的子串。t中的字符可以任意删除。

问题分析:顺序匹配字符串即可。

程序说明:(略)


AC的C语言程序如下:

/* UVA10340 POJ1936 ZOJ1970 All in All */

#include <stdio.h>
#include <string.h>

#define MAXN 110000

char s[MAXN], t[MAXN];

int delstrcmp(char *s, char *t)
{
    int i, j, slen, tlen;

    slen = strlen(s);
    tlen = strlen(t);

    for(i=0, j=0; i<slen && j<tlen;) {
        if(s[i] == t[j]) {
            i++;
            j++;
        } else
            j++;
    }

    return i == slen;
}

int main(void)
{
    while(scanf("%s%s", s, t) != EOF)
        printf("%s\n", delstrcmp(s, t) ? "Yes" : "No");

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值