UVA10474 Where is the Marble?【排序】

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it’s your chance to play as Raju. Being the smartkid, you’d be taking the favor of a computer. But don’t underestimate Meena, she had written a program to keep track how much time you’re taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.

  Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.

  For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

  • ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered 1, 2, . . . , N.

  • ‘x not found’, if the marble with number x is not present.

  Look at the output for sample input for details.

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

 

问题链接UVA10474 Where is the Marble?

题意简述

  输入n个整数,代表大理石编号;再输入q个数(编号),问是否有这个编号的大理石,位置在哪里?

问题分析:(略)

程序说明

  这个问题用C++语言编写程序,主要是为了练习使用STL的功能。

  程序中,使用了算法库(algorithm)中的两个函数;使用sort()函数用于对数据排序,该函数的参数比C语言的同类函数简单,程序更加易于书写;使用函数lower_bound()查找元素,简单方便。

 

AC的C++语言程序如下:

/* UVA10474 Where is the Marble? */

#include <bits/stdc++.h>

using namespace std;

#define MAXN 11000

int marble[MAXN];

int main()
{
    int n, q, caseno=0, val;

    while(scanf("%d%d", &n, &q) != EOF) {
        if(n == 0 && q == 0)
            break;

        for(int i=0; i<n; i++)
            scanf("%d", &marble[i]);

        sort(marble, marble + n);

        printf("CASE# %d:\n", ++caseno);
        while(q--) {
            scanf("%d", &val);
            int no = lower_bound(marble, marble + n, val) - marble;
            if(marble[no] == val)
                printf("%d found at %d\n", val, no + 1);
            else
                printf("%d not found\n", val);
        }
    }

    return 0;
}

 

 

 

 

 

 

  • 5
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值