UVA490 Rotating Sentences【输入输出+水题】

In “Rotating Sentences,” you are asked to rotate a series of input sentences 90 degrees clockwise. Soinstead of displaying the input sentences from left to right and top to bottom, your program will displaythem from top to bottom and right to left.

Input

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100characters long. Legal characters include: newline, space, any punctuation characters, digits, and lowercase or upper case English letters. (NOTE: Tabs are not legal characters.)

Output

The output of the program should have the last sentence printed out vertically in the leftmost column;the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,

"I think, therefore I am."

Sample Output

"R

Ie

n

te

h

iD

ne

kc

,a

r

tt

he

es

r

eo

fn

oc

re

e

s

Ia

i

ad

m,

.

"


问题链接UVA490 Rotating Sentences

题意简述

  输入若干行字符串,将其旋转90度后输出。

问题分析

  需要一个二维数组存储输入的字符串,好在规模不大

程序说明

  封装了函数mygets()(函数gets()在新标准中,被建议不要使用,作用就自己做一个),其他都是套路。


AC的C语言程序如下:

/* UVA490 Rotating Sentences */

#include <stdio.h>
#include <memory.h>

#define MAXN 100

char s[MAXN+1][MAXN+1];

int mygets(char s[])
{
    int i = 0;
    char c;

    while((c = getchar()) && c != '\n' && c != EOF)
        s[i++] = c;
    s[i] = '\0';

    return i;
}

int main(void)
{
    int linecount, maxlen, i, j;

    memset(s, 0, sizeof(s));

    linecount = 0;
    maxlen = 0;
    while(mygets(s[linecount])) {
        i = strlen(s[linecount]);
        if(i > maxlen)
            maxlen = i;
        linecount++;
    }

    for(i=0; i<maxlen; i++) {
        for(j=linecount-1; j>=0; j--)
            putchar((s[j][i] == 0) ? ' ' : s[j][i]);
        putchar('\n');
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值