UVa 490 Rotating Sentences 题解

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."

Sample Output

"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"

这样的题还是直接使用原始的数组来做比较方便,如果使用<string>那么反而是不方便了,看来C++的容器也不是绝对好用的。要看情况而定。


本题注意: 要计算最大长度的行,短行不足需要补足空格的

挺好的题目,这样的题目对于锻炼计算下标准确性的能力可以提高

#include <string.h>
#include <stdio.h>
#include <iostream>
using namespace std;

static char rotateArray[101][101];

void RotatingSentences()
{
	memset(rotateArray, 0, sizeof(rotateArray));
	int row = 0, len = 0;
	while (gets(rotateArray[row]))
	{
		len = max(len, (int)strlen(rotateArray[row++]));
	}
	for (int i = 0; i < row; i++)
	{
		for (int j = 0; j < len; j++)
		{
			if (!rotateArray[i][j]) rotateArray[i][j] = ' ';
		}
	}
	for (int j = 0; j < len; j++) 
	{
		for (int i = row - 1; i >= 0 ; i--)
		{
			cout<<rotateArray[i][j];
		}
		cout<<endl;
	}
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值