POJ2136 Vertical Histogram【打印图案】

32 篇文章 3 订阅
16 篇文章 1 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19827 Accepted: 9483

Description

Write a program to read four lines of upper case (i.e., all CAPITAL LETTERS) text input (no more than 72 characters per line) from the input file and print a vertical histogram that shows how many times each letter (but not blanks, digits, or punctuation) appears in the all-upper-case input. Format your output exactly as shown.

Input

* Lines 1..4: Four lines of upper case text, no more than 72 characters per line.

Output

* Lines 1..??: Several lines with asterisks and spaces followed by one line with the upper-case alphabet separated by spaces. Do not print unneeded blanks at the end of any line. Do not print any leading blank lines.  

Sample Input

THE QUICK BROWN FOX JUMPED OVER THE LAZY DOG.
THIS IS AN EXAMPLE TO TEST FOR YOUR
HISTOGRAM PROGRAM.
HELLO!

Sample Output

                            *
                            *
        *                   *
        *                   *     *   *
        *                   *     *   *
*       *     *             *     *   *
*       *     * *     * *   *     * * *
*       *   * * *     * *   * *   * * * *
*     * * * * * *     * * * * *   * * * *     * *
* * * * * * * * * * * * * * * * * * * * * * * * * *
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Source



问题链接POJ2136 Vertical Histogram

问题简述:参见上文。

问题分析

  统计四行输入的大写字母,根据统计结果输出柱状图。

  该问题的关键是需要一定的想象力,将统计数据转换成相应的图形。

  需要注意的一点是,如果出现次数最多字符的出现次数为max,则输出max行。这是关键的地方。

程序说明:(略)


AC的C++语言程序如下:

/* POJ2136 Vertical Histogram */

#include <iostream>
#include <string>
#include <cstring>
#include <cctype>

using namespace std;

const int MAXN = 26;
int acount[MAXN];

int main()
{
    int linecount, max;
    string s;

    memset(acount, 0, sizeof(acount));

    linecount = 0;
    while (getline(cin, s)) {
        // 统计字母
        for(int i=0; i<(int)s.size(); i++)
//            if(isalpha(s[i]))
//                acount[s[i] - 'A']++;
            if(isupper(s[i]))
                acount[s[i] - 'A']++;

        // 每4行输出一次结果
        if(++linecount == 4) {
            linecount = 0;

            // 计算最大的统计值
            max = 0;
            for(int i=0; i<MAXN; i++)
                if(acount[i] > max)
                    max = acount[i];

            // 输出max行
            for(int i=max; i>0; i--) {
                for(int j=0; j<MAXN; j++) {
                    if(acount[j] >= i)
                        cout << "* ";
                    else
                        cout << "  ";
                }
                cout << endl;
            }

            for(int i=0; i<MAXN; i++)
                cout << (char)('A' + i) << " ";
            cout << endl;
        }
    }

    return 0;
}




  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值