NUC1076 LCD-Display【打印图案】

LCD-Display

时间限制: 1000ms 内存限制: 65536KB

问题描述
A friend of you has just bought a new computer. Until now, the most powerful computer he ever used has been a pocket calculator. Now, looking at his new computer, he is a bit disappointed, because he liked the LC-display of his calculator so much. So you decide to write a program that displays numbers in an LCD-display-like style on his computer
输入描述

The input file contains several lines, one for each number to be displayed. Each line contains two integers s, n (1<=s<=10,0<=n<=99,999,999 ), where n is the number to be displayed and s is the size in which it shall be displayed.

The input file will be terminated by a line containing two zeros. This line should not be processed.

输出描述

Output the numbers given in the input file in an LCD-display-style using s "-" signs for the horizontal segments and s "|" signs for the vertical ones. Each digit occupies exactly s+2 columns and 2s+3 rows. (Be sure to fill all the white space occupied by the digits with blanks, also for the last digit.) There has to be exactly one column of blanks between two digits.

Output a blank line after each number. (You will find a sample of each digit in the sample output.)

样例输入
2 12345
3 67890
0 0
样例输出
      --   --        -- 
   |    |    | |  | |   
   |    |    | |  | |   
      --   --   --   -- 
   | |       |    |    |
   | |       |    |    |
      --   --        -- 

 ---   ---   ---   ---   --- 
|         | |   | |   | |   |
|         | |   | |   | |   |
|         | |   | |   | |   |
 ---         ---   ---       
|   |     | |   |     | |   |
|   |     | |   |     | |   |
|   |     | |   |     | |   |
 ---         ---   ---   ---
来源
Mid-Central European Regional Contest 1999


问题分析:

首先需要一个字模数组,然后进行放大。

每行有多个字,同时需要考虑放大后行数会增加。

需要注意,每组数据后有一个空行,每个数字后有一个空格,每一行后面多一个空格(特殊的地方,需要注意)。

程序说明:

(略)

参考链接:

POJ1102 LC-Display

UVALive5642 UVa706 HDU1332 LC-Display

题记:

显示到处都有,字符显示已经很少见。


AC的C++程序如下:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

string typematrix[10][5] = {
    {
        " - ",
        "| |",
        "   ",
        "| |",
        " - "
    },
    {
        "   ",
        "  |",
        "   ",
        "  |",
        "   "
    },
    {
        " - ",
        "  |",
        " - ",
        "|  ",
        " - "
    },
    {
        " - ",
        "  |",
        " - ",
        "  |",
        " - "
    },
    {
        "   ",
        "| |",
        " - ",
        "  |",
        "   "
    },
    {
        " - ",
        "|  ",
        " - ",
        "  |",
        " - "
    },
    {
        " - ",
        "|  ",
        " - ",
        "| |",
        " - "
    },
    {
        " - ",
        "  |",
        "   ",
        "  |",
        "   "
    },
    {
        " - ",
        "| |",
        " - ",
        "| |",
        " - "
    },
    {
        " - ",
        "| |",
        " - ",
        "  |",
        " - "
    }
};

int getrow(int row, int multiple)
{
    if(row == 0)
        return 0;   // 第1行
    else if(row < multiple + 1)
        return 1;   // 第2行
    else if(row == multiple + 1)
        return 2;   // 第3行
    else if(row == 2 * multiple + 2)
        return 4;   // 第5行
    else
        return 3;   // 第4行
}

void zoom(string& s, int n)
{
    printf("%c",s[0]);
    for(int i=0; i<n; i++) {
        printf("%c", s[1]);
    }
    printf("%c", s[2]);
}

int main()
{
    int n;
    char s[100];

    while(scanf("%d%s", &n, s) != EOF && n) {
        for(int i=0; i<2*n+3; i++) {                // 行控制
            for(int j=0; j<(int)strlen(s); j++) {     // 列控制
                zoom(typematrix[s[j] - '0'][getrow(i, n)], n);
                printf(" ");
            }
            printf("\n");
        }
        printf("\n");
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值