HDU2161 Primes【筛选法+打表】

 

Primes

 

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12512    Accepted Submission(s): 5178

 

 

Problem Description

Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes. 

 

 

Input

Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.

 

 

Output

The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no". 

 

 

Sample Input

 

1 2 3 4 5 17 0

 

 

Sample Output

 

1: no 2: no 3: yes 4: no 5: yes 6: yes

 

 

Source

2008 “Sunline Cup” National Invitational Contest - Warm Up

 

 

 

 

 

问题链接HDU2161 Primes

题意简述:参见上文。

问题分析:用Eratosthenes筛选法设置一个素数判定数组,然后根据输入的正整数判定输出即可。

程序说明:程序中有两个坑,需要注意。

 

参考链接:(略)

 

 

AC的C++语言程序如下:

 

/* HDU2161 Primes */

#include <iostream>
#include <string.h>
#include <math.h>

using namespace std;

const int N = 16000;
bool prime[N+1];

// 筛选法
void sieveofe(int n)
{
    memset(prime, true, sizeof(prime));

    prime[0] = prime[1] = false;
    for(int i=2; i<=sqrt(n); i++) {
        if(prime[i]) {
            for(int j=i*i; j<=n; j+=i)  //筛选
                prime[j] = false;
        }
    }
    prime[2] = false;       // 坑:这是特殊的地方
}

int main()
{
    sieveofe(N);

    int n, caseno=0;

    while(cin >> n && n > 0) {  // 坑:结束条件是n<=0,不是n=0
        cout << ++caseno << ": " << (prime[n] ? "yes" : "no") << endl;
    }
    return 0;
}

 

 

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值