HDU 2161Primes(判断是否是素数)

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

Status

Description

Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.
 

Input

Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.
 

Output

The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no".
 

Sample Input

    
    
1 2 3 4 5 17 0
 

Sample Output

  
  
1: no 2: no 3: yes 4: no 5: yes 6: yes


题意:给出一个数,不是很大的数,问是否是素数

思路:暴力法即可。


<span style="font-size:18px;">#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
using namespace std;

const double PI = acos(-1.0);
const double e = 2.718281828459;
const double eps = 1e-8;

int IsPrime(int n)
{
    if(n==1 || n==2)
        return 0;
    if(n%2 == 0)
        return 0;
    for(int i = 3; i*i <= n; i += 2)
        if(n%i == 0)
            return 0;
    return 1;
}

int main()
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    int n;
    int num = 1;
    while(scanf("%d", &n)!=EOF)
    {
        if(n <= 0)  // 此题的最大坑,没有之一
            break;
        printf("%d: ", num++);
        if(IsPrime(n))
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}

</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值