UVALive6336 HDU4450 Draw Something【水题】

Draw Something

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3698    Accepted Submission(s): 3089

Problem Description

Wangpeng is good at drawing. Now he wants to say numbers like “521” to his girlfriend through the game draw something.
Wangpeng can’t write the digit directly. So he comes up a way that drawing several squares and the total area of squares is the number he wants to say.
Input all the square Wangpeng draws, what’s the number in the picture?

Input
There are multiple test cases.
For each case, the first line contains one integer N(1≤N≤100) indicating the number of squares.
Second line contains N integers ai(1≤ai≤100)represent the side length of each square. No squares will overlap.
Input ends with N = 0.

Output
For each case, output the total area in one line.

Sample Input
  
  
4 1 2 3 4 3 3 3 3 0

Sample Output
  
  
30 27

Source

Regionals 2012 >> Asia - Jinhua


问题链接UVALive6336 HDU4450 Draw Something

问题简述:(略)

问题分析(略)

程序说明:这里给出两个版本的程序。

题记:(略)


参考链接:(略)


AC的C语言程序如下:

/* UVALive6336 HDU4450 Draw Something */

#include <stdio.h>

int main()
{
    int n;
    while (scanf("%d", &n) != EOF) {
        if(n == 0)
            break;

        int sum = 0;
        for(int i=0; i<n; i++) {
            int x;
            scanf ("%d", &x);
            sum += x * x;
        }

        printf ("%d\n", sum);
    }

    return 0;
}


AC的C++语言程序如下:

/* UVALive6336 HDU4450 Draw Something */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int n, m, sum;
    while (scanf("%d", &n) != EOF && n) {
        sum = 0;
        while(n--) {
            scanf ("%d", &m);
            sum += m * m;
        }

        printf ("%d\n", sum);
    }

    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值