POJ1019 ZOJ1410 UVA10706 Number Sequence【数学】

509 篇文章 9 订阅
232 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 40793 Accepted: 11887

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.  
For example, the first 80 digits of the sequence are as follows:  
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2

Source

Tehran 2002, First Iran Nationwide Internet Programming Contest

问题链接POJ1019 ZOJ1410 UVA10706 Number Sequence

问题简述:(略)

问题分析:占个位置。

程序说明

  公式(int)log10((double)i) + 1计算数i的位数(10进制)。

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ1019 ZOJ1410 UVA10706 Number Sequence */

#include <iostream>
#include <math.h>
#include <stdio.h>

using namespace std;

const int N = 31270;
unsigned int a[N], s[N];

void maketable(void)
{
    a[1] = s[1] = 1;
    for(int i=2; i<N; i++) {
        a[i] = a[i-1] + (int)log10((double)i) + 1;
        s[i] = s[i-1] + a[i];
    }
}

int main()
{
    maketable();

    int t, n, i, j, k;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);

        i = 1;
        while(s[i] < n)
            i++;

        int pos = n - s[i-1];
        for(i=1, j=0; j<pos; i++)
            j += (int)log10((double)i) + 1;
        k = j - pos;
        printf("%d\n",(i - 1)/(int)pow(10.0, k) % 10) ;
    }

    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值