HDU1442 UVA739 UVALive5031 Soundex Indexing【编码】

708 篇文章 18 订阅
281 篇文章 4 订阅

Soundex Indexing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 204    Accepted Submission(s): 29


Problem Description
The Soundex Index System was developed so that similar sounding names, or names with similar spelling could be encoded for easy retrieval. It has been used by the U.S. Bureau of the Census, and some States use it to help encode your driver's license number. Your task is to read a sequence of names, one at a time and one per line, compute the corresponding soundex code, and write to the output file the name and its soundex code (one line of output per name).  

Names will contain from 1 to 20 upper case, alphabetic characters (ASCII values 65 thru 90, inclusive). Names shorter than 20 characters will NOT be padded with blanks. Thus a narne will consist of upper case letters only.  


How to generate the Soundex Code:
A Soundex Code always consists of a letter followed by three digits. Here are the rules for soundex encoding:  

1. The first letter of a name appears as the first and only letter in the soundex code.  
2. The letters A, E, I, O, U, Y, W, & H are never encoded, but do break successive code sequences (see next rule).  
3. All other letters are encoded EXCEPT when they immediately follow a letter (including the first letter) that would be encoded with the same code digit.  
4. The soundex code guide is:  

5. Trailing zeros are appended to short codes so all names are encoded with a letter followed by three digits.  
6. Longer codes are truncated after the third digit.  
 

Input
The input file, SOUNDEX.IN, contains a list of names, one per line. Each name will not exceed 20 characters, and you may assume that only upper case letters will be used. Your program should continue to read names until the end of the file is detected.  
 

Output
The output written to the file SOUNDEX.OUT should consist of a column of names and a column of their corresponding soundex codes. Write the headings "NAME" and "SOUNDEX CODE" in the first line of the output file in columns 10 and 35, respectively. After the heading line, the names and soundex codes should be written (one pair per line) with the name starting in column 10 and the soundex code beginning in column 35. The comment "END OF OUTPUT" should appear at the end of the output file on the line immediately after the last name. This comment should be written starting in column 20.  
 

Sample Input
  
  
LEE KUHNE EBELL EBELSON SCHAEFER SCHAAK
 

Sample Output
  
  
NAME SOUNDEX CODE LEE L000 KUHNE K500 EBELL E140 EBELSON E142 SCHAEFER S160 SCHAAK S200 END OF OUTPUT | | | | | |__ Column 35 | |__ Column 20 |__ Column 10
 

Source


Regionals 1993 >> North America - Mid-Central USA


问题链接HDU1442 UVA739 UVALive5031 Soundex Indexing

问题简述:(略)

问题分析:做一个对照表查一下再编码即可。

程序说明

  把编码计算功能封装到函数encode(),使得主函数的逻辑变得简洁,值得推荐。

  需要注意格式。

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* HDU1442 UVA739 UVALive5031 Soundex Indexing */

#include <iostream>
#include <map>

using namespace std;

map<char, char> m;

string encode(const string& s)
{
    string r(s.substr(0, 1));

    for(int i=1; s[i]; i++) {
        if(r.size() == 4)
            break;
        else if(m[s[i]] != 'X' && m[s[i]] != m[s[i - 1]])
            r += m[s[i]];
    }

    if(r.size() < 4)
        r += string(4 - r.size(), '0');

    return r;
}

int main()
{
    m['B'] = m['F'] = m['P'] = m['V'] = '1';
    m['C'] = m['G'] = m['J'] = m['K'] = m['Q'] = m['S'] = m['X'] = m['Z'] = '2';
    m['D'] = m['T'] = '3';
    m['L'] = '4';
    m['M'] = m['N'] = '5';
    m['R'] = '6';
    m['A'] = m['E'] = m['I'] = m['O'] = m['U'] = m['H'] = m['W'] = m['Y'] = 'X';

    cout << string(9, ' ') << "NAME" << string(21, ' ') << "SOUNDEX CODE" << endl;

    string s;
    while(cin >> s)
        cout << string(9, ' ') << s << string(25 - s.size(), ' ') << encode(s) << endl;

    cout << string(19, ' ') << "END OF OUTPUT" << endl;

    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值