POJ2601 Simple calculations【数列】

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6934 Accepted: 3442

Description

There is a sequence of n+2 elements a 0, a 1, ..., a n+1  (n <= 3000, -1000 <= a i <=1000). It is known that   ai = (ai-1 + ai+1)/2 - ci for each i=1, 2, ..., n.  
You are given a 0, a n+1, c 1, ... , c n. Write a program which calculates a 1.

Input

The first line of an input contains an integer n. The next two lines consist of numbers a 0  and a n+1  each having two digits after decimal point, and the next n lines contain numbers c i(also with two digits after decimal point), one number per line.

Output

The output file should contain a 1  in the same format as a 0  and a n+1.

Sample Input

1
50.50
25.50
10.15

Sample Output

27.85

Source


问题链接POJ2601 Simple calculations

问题简述:(略)

问题分析

  数列计算问题。

  先进行数列通项公式的推导,然后再套公式计算,事情就简单了。


程序说明本题与参考链接的题是同一个问题,输入输出格式不同。

题记:数学问题通常是先进行数学推导,再按照数学公式做计算。

参考链接UVA10014 Simple calculations


AC的C语言程序如下:

/* POJ2601 Simple calculations */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int n;
    double a, b, sum = 0;

    while(~scanf("%d", &n)) {
        scanf("%lf%lf", &a, &b);
        for(int i=0; i<n; i++) {
            double x;
            scanf("%lf", &x);
            sum += (n - i) * x;
        }
        printf("%.2f\n", (n * a + b - 2 * sum) / (n + 1.0));
    }

    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值