POJ2260 ZOJ1949 UVA541 Error Correction【水题】

509 篇文章 9 订阅
232 篇文章 0 订阅

Error Correction

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7020 Accepted: 4399

Description

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property: 

1 0 1 0

0 0 0 0

1 1 1 1

0 1 0 1


The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2. 
Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt. 
 

Input

The input will contain one or more test cases. The first line of each test case contains one integer n (n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.

Output

For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".

Sample Input

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0

Sample Output

OK
Change bit (2,3)
Corrupt

Source

Ulm Local 1998

 

问题链接POJ2260 ZOJ1949 UVA541 Error Correction

问题描述:(略)

问题分析

  这是一个奇偶均势矩阵判断问题。

  读入矩阵的同时,统计一下各行各列之和,然后再统计一下,就可以进行判断处理了。如果行和列和为奇数的都只有1个,那就找到奇异点,否则就没有。

程序说明:(略)

参考链接:(略)

题记:(略)

 

AC的C++语言程序如下:

/* POJ2260 ZOJ1949 UVA541 Error Correction */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 100;
int a[N][N], rowsum[N], colsum[N];

int main()
{
    int n;
    while(~scanf("%d", &n) && n) {
        memset(rowsum, 0, sizeof(rowsum));
        memset(colsum, 0, sizeof(colsum));

        // 读入数据和求和
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++) {
                scanf("%d", &a[i][j]);
                rowsum[i] += a[i][j];
                colsum[j] += a[i][j];
            }

        // 计算:基数行列和为奇数的数量,并记住奇异点坐标
        int rcnt = 0, ccnt = 0, row, col;
        for(int i = 0; i < n; i++) {
            if(rowsum[i] % 2)
                rcnt++, row = i;
            if(colsum[i] % 2)
                ccnt++, col = i;
        }

        // 输出结果
        if(rcnt > 1 || ccnt > 1)
            printf("Corrupt\n");
        else if(rcnt == 0 && ccnt == 0)
            printf("OK\n");
        else
            printf("Change bit (%d,%d)\n", row + 1, col + 1);
    }

    return 0;
}

 

 

 

 

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值