HDU 1548 A strange lift(最短路问题Dijkstra & bfs两种解法)

Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5 3 3 1 2 5 0
 

Sample Output
  
  
3
 

//Must so
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
#include<ctype.h>
#include<queue>
#include<vector>
#include<set>
#include<cstdio>
#include<cmath>
#define mem(a,x) memset(a,x,sizeof(a))
#define inf 1<<29
#define NN 1000006
using namespace std;
const double PI = acos(-1.0);
typedef long long LL;

/**********************************************************************
题意:
一个电梯,每层都有一个数字,
当你在i层时,可以选向上走Ki层,或者向下走Ki层
当然,你最高只能到达第n层,最低只能到达第1层
问从A到B,至少走多少次
第一眼觉得是BFS,仔细一想,其实把图构造出来就简单了
每次输入都给出了2条路,从当前位置向上走Ki或向下走Ki
于是map就出来了,然后就是最短路的题了,边权都是1表示步数
**********************************************************************/
int n,s,t;//n个点,起点s,终点t
int d[202];
int mp[202][202];
bool vis[202];
void init()
{
    for (int i = 0;i <= n;i++)
    {
        for (int j = 0;j <= n;j++)
        {
            mp[i][j] = inf;
        }
        mp[i][i] = 0;
        d[i] = inf;
    }
}
void Dijk()
{
    mem(vis,0);
    d[s] = 0;
    for (int i = 1;i <= n;i++)
    {
        int mn = inf,pos;
        for (int j = 1;j <= n;j++)
        {
            if (d[j] < mn&&vis[j] == 0)
            {
                mn = d[j];
                pos = j;
            }
        }
        vis[pos] = 1;
        for (int j = 1;j <= n;j++)
        {
            d[j] = min(d[j],d[pos]+mp[pos][j]);
        }
    }
}
int main()
{
    while (cin>>n)
    {
        if (!n) break;
        cin>>s>>t;
        init();
        for (int i = 1,k;i <= n;i++)
        {
            scanf("%d",&k);
            if (i+k <= n) mp[i][i+k] = 1;//不能超出范围
            if (i-k >= 1) mp[i][i-k] = 1;
        }
        Dijk();
        if (d[t] == inf) puts("-1");
        else printf("%d\n",d[t]);
    }
    return 0;
}


Dijkstra敲完之后觉得BFS也可以。。。

于是又敲了BFS版本。。。其实最短路问题真的很多解法。。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<cmath>
#include<stdlib.h>
#include<cctype>
#define mem(a,x) memset(a,x,sizeof(a))
using namespace std;
typedef long long ll;
int a[10000];
bool vis[1000];
int n,s,t;
struct Node
{
    int x,t;
};
int bfs()
{
    queue<Node>q;mem(vis,0);
    Node h ;h.x = s;h.t = 0;
    q.push(h);
    while (!q.empty())
    {
        h = q.front();
        if (h.x == t) return h.t;
        q.pop();
        Node nx ;
        nx.x = h.x + a[h.x];
        nx.t = h.t + 1;
        if (nx.x<=n&&!vis[nx.x])
        {
            vis[nx.x] = 1;
            q.push(nx);
        }
        nx.x = h.x - a[h.x];
        nx.t = h.t +1;
        if (nx.x>=1&&!vis[nx.x])
        {
            vis[nx.x] = 1;
            q.push(nx);
        }
    }
    return -1;
}
int main()
{
    while (scanf("%d",&n) == 1&&n)
    {
        scanf("%d %d",&s,&t);
        for (int i = 1;i <= n;++i) scanf("%d",a+i);
        printf("%d\n",bfs());
    }
    return 0;
}


【6层】一字型框架办公楼(含建筑结构图、计算书) 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值