HDU 1548 A strange lift(最短路、BFS)

A strange lift
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,….kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.
Sample Input
5 1 5
3 3 1 2 5
0
Sample Output
3
题目大意:搭乘电梯从A楼到B楼,电梯的规则是:每层电梯只能到达i+ki或i-ki层,问至少按几次按钮才能到达目标层。
一开始:我用深搜(DFS)加回溯,TLE。o(╯□╰)o

#include<iostream>
#include<vector>
#include<cstring>
#include<cstdlib>
#define maxn 0x3f3f3f3f
using namespace std;
vector<int> Adj[204];
bool visited[204];
int N, A, B, ans;
int flag;
int res;
void DFS(int u, int ans)
{
    visited[u] = true;
    if(u == B){
        flag = 1;
        if(res > ans)res = ans;
        return ;
    }
    for(int i = 0; i < Adj[u].size(); i++)
    {
        int v = Adj[u][i];
        if(visited[v] == false)
        {
            DFS(v,ans + 1);//从当前楼层开始深搜
            visited[v] = false;
        }
    }
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>N && N != 0)
    {
        cin>>A>>B;
        int temp;
        for(int i = 1; i <= N; i++)
            Adj[i].clear();
        ans = 0;
        flag = 0;
        res = maxn;
        memset(visited, 0, sizeof visited);
        for(int i = 1; i <= N; i++)
        {
            cin>>temp;
            int j = i + temp;
            int k = i - temp;
            if(j > 0 && j <= N && j != i) Adj[i].push_back(j);
            if(k > 0 && k <= N && k != i) Adj[i].push_back(k);
        }
        DFS(A,ans);
        if(flag == 1)cout<<res<<endl;
        else cout<<-1<<endl;
    }
    return 0;
}

后来,尝试用最短路(Dijkstra)解决,AC了。

#include<iostream>
#include<vector>
#include<cstring>
#include<cstdio>
#define MAXV 300
using namespace std;
int N,A,B;
struct Node
{
    int v, dis; //v为边的目标顶点,dis为边权
    Node(int _v, int _dis):v(_v),dis(_dis){}
};
vector<Node> Adj[MAXV];//图G,Adj[u]存放从顶点u出发可以到达的所有顶点
int n;//n为顶点数
int d[MAXV];//起点到达各点的最短路径长度
bool vis[MAXV] = {false};//标记数组,vis[i] == ture表示已访问。初值均为false
const int INF = 0x3fffffff;
int flag;
void Dijkstra(int s)
{//s为起点
    fill(d, d + MAXV, INF);
    d[s] = 0; //起点s到达自身的距离为0
    n = N;
    for(int i = 0; i < n; i++)
    {//循环n次
        int u = -1, MIN = INF; //u使d[u]最小,MIN存放该最小的d[u]
        for(int j = 1; j <= n; j++)
        {//找到未访问顶点中d[]最小的
            if(vis[j] == false && d[j] < MIN){
                u = j;
                MIN = d[j];
            }
        }
        if(u == -1) return ;//找不到小于INF的d[u],说明剩下的顶点和起点s不连通
        vis[u] = true; //标记u为已访问
        for(int j = 0; j < Adj[u].size(); j++)
        {
            int v = Adj[u][j].v; //通过邻接表获得u能到达的顶点v
            if(vis[v] == false && d[u] + Adj[u][j].dis < d[v]){
                //如果v未访问 && 以u为中介点可以使d[v]更优
                d[v] = d[u] + Adj[u][j].dis; //优化d[v]
            }
        }
    }
}
int main()
{
    while(cin>>N && N != 0)
    {
        memset(vis, 0, sizeof vis);
        for(int i = 1; i <= N; i++)
            Adj[i].clear();
        cin>>A>>B;
        int ki;
        for(int i = 1; i <= N; i++)
        {
            cin>>ki;
            int up = i + ki;
            int down = i - ki;
            if(up > 0 && up <= N && up != i){
                Adj[i].push_back(Node(up,1));
            }
            if(down > 0 && down <= N && up != i){
                Adj[i].push_back(Node(down,1));
            }
        }
        Dijkstra(A);
        if(d[B] != INF)
        cout<<d[B]<<endl;
        else cout<<-1<<endl;
    }
    return 0;
}

再尝试广搜(BFS),也过了。ヾ(≧▽≦*)o

#include<iostream>
#include<vector>
#include<queue>
#include<cstring>
#include<cstdlib>
#define maxn 0x3f3f3f3f
using namespace std;
vector<int> Adj[204];
bool visited[204];
int N, A, B, ans;
int flag;
int res;
struct NODE
{
    int floor; //当前楼层的层数
    int step;//当前的操作步数
};
void BFS(NODE ans)
{
    queue<NODE> q;
    q.push(ans);
    visited[ans.floor] = true;
    while(!q.empty())
    {
        NODE u = q.front();
        q.pop();
        if(u.floor == B){
            flag = 1;
            cout<<u.step<<endl;
            break;
        }
        for(int i = 0; i < Adj[u.floor].size(); i++)
        {
            int v = Adj[u.floor][i];
            if(visited[v] == false)
            {
                NODE temp = u; //这里是比较巧妙的地方
                temp.floor = v;
                temp.step++; 
                q.push(temp);
                visited[v] = true;
            }
        }
    }
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>N && N != 0)
    {
        cin>>A>>B;
        int temp;
        for(int i = 1; i <= N; i++)
            Adj[i].clear();
        flag = 0;
        res = 0;
        memset(visited, 0, sizeof visited);
        for(int i = 1; i <= N; i++)
        {
            cin>>temp;
            int j = i + temp;
            int k = i - temp;
            if(j > 0 && j <= N && j != i) Adj[i].push_back(j);
            if(k > 0 && k <= N && k != i) Adj[i].push_back(k);
        }
        NODE ans;
        ans.floor = A;
        ans.step = 0;
        BFS(ans);
        if(flag != 1) cout<<-1<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值