PAT (Advanced Level) 1039. Course List for Student (25) 排序,手动写哈希

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
一开始用map写,最后一个case超时。
/*2015.7.24cyq*/
#include <iostream>
#include <map>
#include <string>
#include <algorithm>
#include <vector>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

int main(){
	int N,K;
	scanf("%d%d",&N,&K);
	map<string,vector<int> > map;

	int course,m;
	char stuName[5];
	string name;
	for(int i=0;i<K;i++){
		scanf("%d%d",&course,&m);
		for(int j=0;j<m;j++){
			scanf("%s",stuName);
			name=string(stuName);
			map[name].push_back(course);
		}
	}
	for(int i=0;i<N;i++){
		scanf("%s",stuName);
		name=string(stuName);
		if(map.find(name)==map.end()){
			cout<<name;
			printf(" 0\n");
		}
		else{
			sort(map[name].begin(),map[name].end());
			int len=map[name].size();
			cout<<name;
			printf(" %d",len);
			for(int it=0;it<len;it++)
				printf(" %d",map[name][it]);
			printf("\n");
		}
	}
	return 0;
}
自己写一个哈希表才能AC,哈希表长度为26*26*26*10,元素为vector<int>,用来存储所有课程序号。
/*2015.7.24cyq*/
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

vector<vector<int> > stu(26*26*26*10);
int hashn(char* name){
	return (((name[0]-'A')*26+name[1]-'A')*26+name[2]-'A')*10+name[3]-'0';
}
int main(){
	int N,K;
	scanf("%d%d",&N,&K);
	int course,m;
	char name[5];
	for(int i=0;i<K;i++){
		scanf("%d%d",&course,&m);
		for(int j=0;j<m;j++){
			scanf("%s",name);
			stu[hashn(name)].push_back(course);
		}
	}
	for(int i=0;i<N;i++){
		scanf("%s",name);
		if(stu[hashn(name)].empty()){
			printf("%s 0\n",name);
		}
		else{
			sort(stu[hashn(name)].begin(),stu[hashn(name)].end());
			int len=stu[hashn(name)].size();
			printf("%s %d",name,len);
			for(int it=0;it<len;it++)
				printf(" %d",stu[hashn(name)][it]);
			printf("\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值