PAT (Advanced Level) 1074. Reversing Linked List (25) 翻转链表

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
这道题的代码之前写过了,写法是将其当成真实的链表进行模拟操作 PAT 数据结构 02-线性结构1. Reversing Linked List (25),写起来略繁琐。

注意到题目给的用例是静态链表,这次我直接将链表头及之后的结点顺序压入数组,每K个进行翻转,写起来非常快。
/*2015.7.29cyq*/
#include <iostream>
#include <vector>
#include <fstream>
using namespace std;

//fstream fin("case1.txt");
//#define cin fin

struct LNode{
	int addr;
	int val;
	int next;
};
void reverse(vector<LNode> &res,int begin,int end){
	while(begin<end){
		swap(res[begin],res[end]);
		begin++;
		end--;
	}
}
int main(){
	int head,N,K;
	cin>>head>>N>>K;
	vector<LNode> L(100000);
	int a,b,c;
	for(int i=0;i<N;i++){
		cin>>a>>b>>c;
		L[a].addr=a;
		L[a].val=b;
		L[a].next=c;
	}
	vector<LNode> result;
	int p=head;
	while(p!=-1){
		result.push_back(L[p]);
		p=L[p].next;
	}
	int len=result.size();
	int count=len/K; //翻转的次数
	for(int i=0;i<count;i++){
		reverse(result,i*K,(i+1)*K-1);
	}
	for(int i=0;i<len-1;i++){
		result[i].next=result[i+1].addr;
		printf("%05d %d %05d\n",result[i].addr,result[i].val,result[i].next);
	}
	result[len-1].next=-1;
	printf("%05d %d %d\n",result[len-1].addr,result[len-1].val,result[len-1].next);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值