PAT (Advanced Level) 1088. Rational Arithmetic (20) 分数四则运算

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:
2/3 -4/2
Sample Output 1:
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)
Sample Input 2:
5/3 0/6
Sample Output 2:
1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf
主要是两个函数,一是求最大公约数,二是给定分子和分母,化成整数加分数形式的字符串,负数需要带括号。
使用long long防止溢出。
/*2015.7.25cyq*/
#include <iostream>
#include <string>
#include <sstream>
using namespace std;

long long gcd(long long a,long long b){
	long long r;
	while(b!=0){
		r=a%b;
		a=b;
		b=r;
	}
	return a;
}

string f(long long a,long long b){//保证b!=0
	if(a==0)
		return "0";
	stringstream ss;
	string s;
	int flag=1;
	if(a<0){
		flag=-1;
		a=-a;
		ss<<"(-";
	}
	long long tmp=gcd(a,b);
	a=a/tmp;
	b=b/tmp;
	if(a%b==0){//只有整数部分
		ss<<a/b;
	}else if(a/b>0){//整数部分加分数
		ss<<a/b<<" ";
		ss<<a%b<<"/"<<b;
	}else{//只有分数部分
		ss<<a<<"/"<<b;
	}
	if(flag==-1)
		ss<<")";
	getline(ss,s);//由于ss可能有空格,用getline
	return s;
}
int main(){
	long a1,b1,a2,b2;
	scanf("%ld/%ld %ld/%ld",&a1,&b1,&a2,&b2);
	long long sum1,sum2,sub1,sub2,mul1,mul2,div1,div2;
	sum1=a1*b2+a2*b1;
	sum2=b1*b2;
	sub1=a1*b2-a2*b1;
	sub2=b1*b2;
	mul1=a1*a2;
	mul2=b1*b2;
	string s1=f(a1,b1);
	string s2=f(a2,b2);
	cout<<s1<<" + "<<s2<<" = "<<f(sum1,sum2)<<endl;
	cout<<s1<<" - "<<s2<<" = "<<f(sub1,sub2)<<endl;
	cout<<s1<<" * "<<s2<<" = "<<f(mul1,mul2)<<endl;
	cout<<s1<<" / "<<s2<<" = ";
	if(a2==0){
		cout<<"Inf";
	}else{
		div1=a1*b2;
		div2=b1*a2;
		if((div1<0&&div2<0)||(div1>0&&div2<0)){
			div1=-div1;
			div2=-div2;
		}
		cout<<f(div1,div2);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值