poj3041 二分图最小顶点覆盖

 

如题:http://poj.org/problem?id=3041

 

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16442 Accepted: 8967

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

 

 

思路:每一道光束摧毁一行或一列,我们将每一个给出的点作为一个顶点,相同横坐标或相同纵坐标就连一条线代表光束。最终要求的就是所有的边都是顶点关联。简化后就变成将横坐标看恒一个顶点集合,纵坐标一个顶点集合,从搜友给出的横纵坐标集合中,每一个横坐标连一条边到纵坐标,求最小顶点覆盖。

又因为二分图最小订点覆盖=最大匹配。问题解决

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAXN 550
int N,K;
int G[MAXN][2*MAXN];
int vis[MAXN*2];
int match[MAXN*2];

int dfs(int v)
{
 int i;
 for(i=N+1;i<=2*N;i++)
 {
  if(!vis[i]&&G[v][i]==1)
  {
   vis[i]=v;
   if(match[i]==-1||dfs(match[i]))
   {
    match[i]=v;
    return 1;
   }
  }
 }
 return 0;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
 cin>>N>>K;
 int i;
 for(i=0;i<K;i++)
 {
  int x,y;
  scanf("%d%d",&x,&y);
  G[x][y+N]=1;
 }
 memset(match,-1,sizeof(match));
 int res=0;
 for(i=1;i<=N;i++)
 {
  memset(vis,0,sizeof(vis));
  if(dfs(i))
   res++;
 }
 printf("%d\n",res);
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值