poj 3020 Antenna Placement

题目链接:点击打开链接

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

题目大意:给出图(如上图),*代表城市,o代表空地,要把所有的城市都装上电线,每个城市可以和他的上下左右链接,问最少需要多少基站可以实现所有城市的链接


基本思路:最小路径的的覆盖问题=n-二分图最大匹配数.

建图要将所有的城市作为基点,如果变成二分图的话,每个基点表示两个(这是基点的拆点问题),就是在求出最大匹配数时除以2;

///当二分图的两个顶点子集基数相等时,
///该二分图所有顶点的匹配数 等于 任意一个顶点子集匹配数的2倍
#include <iostream>

#include<cstring>

using namespace std;
int mp[450][450];
int city[454][444];
int dx[]={-1,1,0,0};
int dy[]={0,0,-1,1};
int vis[1000];
int link[1000];
int top;
int dfs(int k)
{
    for(int i=1;i<top;i++)
    {
        if(vis[i]==0&&city[k][i])
        {
            vis[i]=1;
            if(link[i]==-1||dfs(link[i]))
            {
                link[i]=k;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int t;
    cin>>t;
    int h,w;
    char ch;

    while(t--)
    {

        cin>>h>>w;
        top=0;
        memset(mp,0,sizeof(mp));
        for(int i=0;i<h;i++)
        {
                for(int j=0;j<w;j++)
                {
                    cin>>ch;
                    if(ch=='*')
                    {
                        mp[i][j]=++top;
                    }
                }
        }
        memset(city,0,sizeof(city));
        for(int i=0;i<h;i++)
        {
            for(int j=0;j<w;j++)
            {
                if(mp[i][j])
                {
                    for(int k=0;k<4;k++)
                    {
                        int x=i+dx[k];
                        int y=j+dy[k];
                        if(x>=0&&y>=0&&x<h&&y<w&&mp[x][y])
                        {
                            city[mp[i][j]][mp[x][y]]=1;
                        }
                    }
                }
            }
        }
        int num=0;
        memset(link,-1,sizeof(link));
        for(int i=1;i<=top;i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))num++;
        }
        if(num%2==1)num=num/2+1;
        else num=num/2;
        cout<<top-num<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值