hdu 1082 Matrix Chain Multiplication

Matrix Chain Multiplication

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 797    Accepted Submission(s): 553


Problem Description
Matrix multiplication problem is a typical example of dynamical programming.

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.
 

Input
Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"
 

Output
For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.
 

Sample Input
  
  
9 A 50 10 B 10 20 C 20 5 D 30 35 E 35 15 F 15 5 G 5 10 H 10 20 I 20 25 A B C (AA) (AB) (AC) (A(BC)) ((AB)C) (((((DE)F)G)H)I) (D(E(F(G(HI))))) ((D(EF))((GH)I))
 

Sample Output
  
  
0 0 0 error 10000 error 3500 15000 40500 47500 15125
#include<iostream>
#include<cstdio>
#include<stack>
#include<string>
using namespace std;

struct Tnode
{
	int r,l;
}node[30];                     // 记录所给矩阵名称对应的行和列  由于名称从'A'到'Z' 故最好将下标处理成字母对应数字 即'A'对1 'B'对2...
char s[1005];            
int row[1005],line[1005];      // 模拟栈  将对应的矩阵的行列记录其中  
int ans,t,n;

bool cal()
{
	int i,j,r1,l1,r2,l2;
	if(t==1) return true;
	r1=row[t];
	l1=line[t];
	r2=row[t-1];
	l2=line[t-1];
	if(l1!=r2) return false;
	else 
	{
		ans+=r1*l2*l1;
		t--;
		row[t]=r1;
		line[t]=l2;
		return true;
	}
}
int main()
{
    int i,j,t1,t2,flag;
	char c;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		getchar();
		scanf("%c%d%d",&c,&t1,&t2);
		node[c-'A'+1].l=t1;
		node[c-'A'+1].r=t2;
	}
	getchar();
    while(gets(s)!=NULL)
    {
		ans=0;
		t=0;
		flag=0;
        for(i=0;s[i]!='\0';i++)
		{
			if(s[i]=='(') continue;
			else if(s[i]>='A'&&s[i]<='Z')            // 为字母则进栈
			{
				row[++t]=node[s[i]-'A'+1].r;
				line[t]=node[s[i]-'A'+1].l;
			}
			else if(s[i]=')')                       // 为')'则出栈两个 计算  再进栈一个
			{
				if(!cal())                      
				{
					flag=1;
					printf("error\n");     
					break;
				}
			}
		}
		if(!flag) printf("%d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值