杭电ACM题1007

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43918    Accepted Submission(s): 11417


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75 分析题目可知,这题就是要求任意2点之间最短的距离 ,唉,好难啊,我需要停一停咯
#include "stdafx.h" 
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;

static const int MAXNUM=100000;

struct Point
{
 double x,y;
}arrP[MAXNUM],arrX[MAXNUM],arrY[MAXNUM];

bool CompX(Point a,Point b)
{
 if(a.x==b.x)
  return a.y<b.y;
 return a.x<b.x;
}

bool CompY(Point a,Point b)
{
 if(a.y==b.y)
  return a.x<b.x;
 return a.y<b.y;
}

double GetDistance(Point a,Point b)
{
 return sqrt(pow(a.x-b.x,2.0)+pow(a.y-b.y,2.0));
}

double MinDistance(double a,double b)
{
 return a<=b ? a : b;
}

double GetMinDistance(int l,int r)
{
 if(l==r)   //only one point
  return 0;
 else if(l+1==r)  //only two points
  return GetDistance(arrP[l],arrP[r]);
 else if(l+2==r)  //only three points
 {
  double tmp1=GetDistance(arrP[l],arrP[l+1]);
  double tmp2=GetDistance(arrP[l],arrP[r]);
  double tmp3=GetDistance(arrP[l+1],arrP[r]);
  return MinDistance(MinDistance(tmp1,tmp2),tmp3);
 }
 //more than three points
 int middle=(l+r)/2,j=0,k=0;
 double minDistance=MinDistance(GetMinDistance(l,middle),GetMinDistance(middle+1,r));
 for(int i=l;i<=r;i++)
 {
  if(fabs(arrP[i].x-arrP[middle].x)<minDistance)
   arrX[j++]=arrP[i];
 }
 sort(arrX,arrX+j,CompY);
 middle=(j+1)/2;
 for(int i=0;i<j;i++)
 {
  if(fabs(arrX[i].y-arrX[middle].y)<minDistance)
   arrY[k++]=arrX[i];
 }
 for(int i=0;i<k;i++)
  for(int j=i+1;j<k;j++)
  {
   double tmpDistance=GetDistance(arrY[i],arrY[j]);
   if(tmpDistance<minDistance)
    minDistance=tmpDistance;
  }
 return minDistance;
}

int main()
{
 int n;
 while(cin>>n && n!=0)
 {
  Point p;
  double minDistance;
  for(int i=0;i<n;i++)
  {
   cin>>arrP[i].x>>arrP[i].y;
  }
  sort(arrP,arrP+n,CompX);
  minDistance=GetMinDistance(0,n-1);
  cout.precision(2);
  cout<<fixed<<minDistance/2<<endl;
 }
 return 0;
}
http://blog.163.com/jackie_howe/blog/static/199491347201232553039178/
 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值