poj1700Crossing River(这过河真经典)

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17
题目意思:每个人过河都有自己的过河时间,有n个人想过河,但只有一只小船,最多只能装2个人,每一次过河,过河时间为用时最多的那人过河时间,如果还有人没有过河,那么过去一个用时最少的送回船。问n人过河最少要多少时间。
解题:当n<4时,有三种情况,(n=1,n=2,n=3)。当n>=4时,如果剩余人数大于3人,那么每次把 最少用时a,次少用时b,剩余人当中最大用时c和次大用时d,看成一个组合,借a和b两个送走c,d。a和b两人还是没有过河,剩余的人又可以组成全新的(包a,b)。重复。当剩余人数等于3时,a,c过河,再a反回,再a,b过河。
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int cmp(int a,int b){return a<b;}
int main()
{
    int time,t,n,ne[1005],k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n); ne[2]=0;
        for(int i=0;i<n;i++)
        scanf("%d",&ne[i]);
        sort(ne,ne+n,cmp);//从小到大排一次序
        time=0;
        if(n<=3)//小于等于3个人时
        {
            if(n==1)time=ne[0];
            if(n==2)time=ne[1];
            if(n==3) time=ne[1]+ne[2]+ne[0];
        }
        else//大于3个人时
        {//把4人看成一组
            for(int i=n-1;i>1;i-=2)//每一次送完2人或1人,最小和次小都在剩于人当中
            if(i>=3)//还剩下大于等于4个人时,送走剩余当中最大和次大两个人
            {
                if(ne[0]+ne[i-1]>=2*ne[1])
                    time+=ne[1]+ne[0]+ne[i]+ne[1];
                else
                    time+=ne[i]+ne[0]+ne[i-1]+ne[0];
            }
            else//只剩3人时(最小,次小,次次小),送走用时次次小
                time+=ne[2]+ne[0];
                
             time+=ne[1];//最后用时最少两人一起过
        }
        printf("%d\n",time);
    }
}


  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值