Poj 1700 Crossing River——过河问题(贪心)

Crossing River

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.
Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input

1
4
1 2 5 10

Sample Output

17

题意: 有n个人要过河,一艘船,这艘船一次只能载两个人。现在给出每个人过河所需要的时间,求最小的所有人的过河时间。
 

题解: 首先,我们将每个人过河需要花费的时间升序排序(从s[1]-s[n])。再而,我们将需要过河的人群分为两大类:

  • 人数小于等于3人:当n为1时 → \rightarrow 花费的time(以下均用time代替总时间)为s[1];当n为2时time为s[2];当n为3时,time为s[1] + s[2] + s[3]。
  • 人数超过3人:这里我们就要分情况来讨论了。从以下两种决策中取time最小的。
    • 始终让最快的人把船划回来。最快的和最慢的一起渡河,然后最快的化回来,最快的和次慢的一起渡河,最快的再回来。time = s[n] + s[1] + s[n-1] + s[1]
    • 让最快和次快的先过河,最快的划回来,接着最慢和次慢的过河,次快的把船划回来。time = s[2] + s[1] + s[n] + s[2]。

c++ AC 代码

#include<iostream>
#include<algorithm>
#include<cstdio>

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,s[1010];
        scanf("%d",&n);
        for(int i=1;i<n+1;i++)
            scanf("%d",&s[i]);
        std::sort(s+1,s+1+n);
        int time=0;
        while(n)
        {
            if(n==1)
            {
                time += s[1];
                break;
            }
            else if(n==2)
            {
                time += s[2];
                break;
            }
            else if(n==3)
            {
                time += s[1] + s[2] + s[3];
                break;
            }
            else
            {
                time += std::min(2*s[2]+s[1]+s[n],2*s[1]+s[n]+s[n-1]);
                n -= 2;
            }
        }
        printf("%d\n",time);
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值