hdu1317XYZZY (SPFA处理 有环的情况)

Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable.
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:

the energy value for room i
the number of doorways leaving room i
a list of the rooms that are reachable by the doorways leaving room i
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".

Sample Input
  
  
5 0 1 2 -60 1 3 -60 1 4 20 1 5 0 0 5 0 1 2 20 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 21 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 20 2 1 3 -60 1 4 -60 1 5 0 0 -1

Sample Output
  
  
hopeless hopeless winnable winnable
题目意思:有n个点,开始有100能量从1开始,走到点n,每走到一个点就加上所走的路的权值(有正有负),途中能量要大于0才能走,如果能到达点n就输出winnable,否则输出hopelsee. 输入有n行,第i行的第一个数为权值p,第二个值为有k个点,后跟k个点,p为第i个点到k个点的权值。
解题:根据SPFA性质,如果一个点进队n+1次,说明这个点在一个正环上。
#include<stdio.h>
#include<queue>
#include<iostream>
using namespace std;
#define MIN -999999999
int map[105][105],d[105],n;
void init()//初始化
{
    int i,j;
    for(i=1;i<=n;i++)
    {
        d[i]=MIN;
        for(j=1;j<=n;j++)
        map[i][j]=MIN;
    }
}
int spfa(int s)
{
    if(n==1) return 1;
    queue<int>q;
    int inq[105]={0},vist[105]={0};
    d[s]=100; //题目意思是最开始能量是100
    inq[s]=1;
    q.push(s);
    while(!q.empty())
    {
        s=q.front();q.pop();
        vist[s]++;  //点s进队vist[s]次
        if(vist[s]==n+2) continue;//如果进队大于n+1次了,说明与s点有关的点都得到了正环的利益
        inq[s]=0;
        if(vist[s]==n+1) d[s]=100000;//说明s是在正环上,那么d[s]可以变成很大的数,根据题目两个点最小距离为-100*100,所以100000足以.

        for(int i=1;i<=n;i++)
        if(map[s][i]!=MIN)
        {
            if(d[i]<d[s]+map[s][i]&&d[s]+map[s][i]>0)//判断大于0,就是能量不能用完才能往下走
            {
                d[i]=d[s]+map[s][i];
                if(d[n]>0) return 1;//走到第n点
                if(!inq[i])
                inq[i]=1,q.push(i);
            }
        }
    }
    return 0;
}
int main()
{
    int p,a,k;
    while(scanf("%d",&n)>0&&n!=-1)
    {
        init();
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&p,&k);
            while(k--)
            {
                scanf("%d",&a);
                 map[i][a]=p;
            }
        }
        int flog=spfa(1);
        printf("%s\n",flog?"winnable":"hopeless");
    }
}


  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值