hdu1247Hat’s Words (组合单词,字典树+DFS)

Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary. You are to find all the hat’s words in a dictionary.

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words. Only one case.

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input
  
  
a ahat hat hatword hziee word

Sample Output
  
  
ahat hatword
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
typedef struct nn
{
    int flag;
    struct nn *next[26];
}node;
typedef struct strin
{
    int len,indx;
    char str[105];
}String;
int cmp(String s1,String s2)
{
    return s1.len<s2.len;
}
int cmp1(String s1,String s2)
{
    return s1.indx<s2.indx;
}
node *builde()
{
    node *p=new node;
    p->flag=0;
    for(int i=0;i<26;i++)
    p->next[i]=NULL;
    return p;
}
node *root;
void insert(char s[])
{
    node *p=root;
    for(int i=0;s[i]!='\0';i++)
    {
        if(p->next[s[i]-'a']==NULL)
        p->next[s[i]-'a']=builde();
        p=p->next[s[i]-'a'];
    }
    p->flag=1;
}
String s[50005];
int flog;
void dfs(int k,int si,int num)
{
    node *p=root;
    if(num>2)
         return ;
    if(si==s[k].len)
    {
        if(num==2)flog=1; return ;
    }

    for(int j=si;j<s[k].len;j++)
    {
        if(p->next[s[k].str[j]-'a']==NULL)
            return ;
        p=p->next[s[k].str[j]-'a'];
        if(p->flag)
        {
            dfs(k,j+1,num+1); if(flog!=0) return ;
        }
    }
}
int main()
{
    int n=0,m=0;
    while(scanf("%s",s[n].str)>0&&s[n].str[0]!='#')
    {
        s[n].len=strlen(s[n].str); s[n].indx=n; n++;
    }
    sort(s,s+n,cmp);
    root=builde();
    for(int i=0;i<n;i++)
    {
       flog=0; dfs(i,0,0);
       if(flog==1)s[m++]=s[i];
       insert(s[i].str);
    }
    sort(s,s+m,cmp1);
    for(int i=0;i<m;i++)
    printf("%s\n",s[i].str);
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值