HDU-1274 Hat’s Words(Trie树)

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13640    Accepted Submission(s): 4872


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
  
  
a ahat hat hatword hziee word
 

Sample Output
  
  
ahat hatword
 

Author
戴帽子的
 
题意:输入一系列字符串,判断是否有字符串满足,由两个输入的字符串组成,将这样的字符串输出。
思路:枚举每个字符串,然后枚举其单词断点,看是否能由两个单词组成。开始没想到,而且Trie树也没用多好啊

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 50005;
char str[N][55];
inline int idx(char c){return c-'a';}
struct Trie
{
    int cnt;
    Trie *next[26];
    Trie()
    {
        cnt = 0;
        memset(next,0,sizeof(next));
    }
};

Trie *root;

void Insert(char *word)
{
    Trie *tmp = root;
    for(int i = 0;word[i] != '\0';i++)
    {
        int x= idx(word[i]);
        if(tmp->next[x] == NULL)
            tmp->next[x] = new Trie;
        tmp = tmp->next[x];
        
    }
    tmp->cnt = 1;
}

int Query(char *word)
{
    Trie *tmp = root;
    for(int i = 0;word[i] != '\0';i++)
    {
        int x = idx(word[i]);
        if(tmp->next[x] == NULL)
            return 0;
        tmp = tmp->next[x];
    }
    return tmp->cnt;
}
/*
void del(Trie *root)
{
    for(int i=0;i<26;i++)
    {
        if(root->next[i])
            del(root->next[i]);
    }
    free(root);
}
*/
int main()
{
    root = new Trie;
    int num = 0;
    while(~scanf("%s",str[num]))
    {
        Insert(str[num]);
        num++;
    }


    for(int i = 0;i < num;i++)
    {
        int len = strlen(str[i]);
        for(int j = 1;j < len;j++)
        {
            char p[55]={'\0'},q[55]={'\0'};
            strcpy(p,str[i]);
            p[j] = '\0';
            strcpy(q,str[i]+j);
            if(Query(p) && Query(q))
            {
                printf("%s\n",str[i]);
                break;
            }
        }
    }
    //del(root);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值