hdu1538 A Puzzle for Pirates

67 篇文章 1 订阅

A Puzzle for Pirates

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 289 Accepted Submission(s): 92


Problem Description
A bunch of pirates have gotten their hands on a hoard of gold pieces and wish to divide the loot. They are democratic pirates in their own way, and it is their custom to make such divisions in the following manner: The fiercest pirate makes a proposal about the division, and everybody votes on it, including the proposer. If 50 percent or more are in favor, the proposal passes and is implemented forthwith. Otherwise the proposer is thrown overboard, and the procedure is repeated with the next fiercest pirate.
All the pirates enjoy throwing one of their fellows overboard, but if given a choice they prefer cold, hard cash, the more the better. They dislike being thrown overboard themselves. All pirates are rational and know that the other pirates are also rational. Moreover, no two pirates are equally fierce, so there is a precise pecking order — and it is known to them all. The gold pieces are indivisible, and arrangements to share pieces are not permitted, because no pirate trusts his fellows to stick to such an arrangement. It's every man for himself. Another thing about pirates is that they are realistic. They believe 'a bird in the hand is worth two in the bush' which means they prefer something that is certain than take a risk to get more, where they might lose everything.

For convenience, number the pirates in order of meekness, so that the least fierce is number 1, the next least fierce number 2 and so on. The fiercest pirate thus gets the biggest number, and proposals proceed in the order from the biggest to the least.

The secret to analyzing all such games of strategy is to work backward from the end. The place to start is the point at which the game gets down to just two pirates, P1 and P2. Then add in pirate P3, P4, ... , one by one. The illustration shows the results when 3, 4 or 5 pirates try to divide 100 pieces of gold.



Your task is to predict how many gold pieces a given pirate will get.

Input
The input consists of a line specifying the number of testcases, followed by one line per case with 3 integer numbers n, m, p. n (1 ≤ n ≤ 10^4) is the number of pirates. m (1 ≤ m ≤ 10^7) is the number of gold pieces. p (1 ≤ p ≤ n) indicates a pirate where p = n indicates the fiercest one.

Output
The output for each case consists of a single integer which is the minimal number of gold pieces pirate p can get. For example, if pirate p can get 0 or 1 gold pieces, output '0'. If pirate p will be thrown overboard, output 'Thrown'.

Sample Input
  
  
3 3 100 2 4 100 2 5 100 5

Sample Output
  
  
0 1 98
Hint
Hint
The situation gets complicated when a few gold pieces were divided among many pirates.
1:如果n<=2*m+1决策者得到m-(n-1)/2个,非决策者,如果,与决策都奇偶相同得到1个否则是0个.2:n==2*m+2^k,刚决策者得到0个,其它人因为不确定得到都是0个,3:如果n>2*m+1且非2中的情况,则当是决策者的时候,是得扔出去的,不是决策者的时候,就不确定为0!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int pri[14]={2,4,8,16,32,64,128,256,512,1024,2048,4096,8192,16384};
int solve(int n,int m,int p){
    int i,m2=2*m;
    if(n<=m2+1){
        if(p!=n&&((p&1)==(n&1)))
        printf("1\n");
        else if(p==n)
        printf("%d\n",m-(n-1)/2);
        else
        printf("0\n");
        return 1;
    }
    int temp=n-m2;
    for(i=0;i<14;i++){
        if(temp==pri[i]){
            printf("0\n");
            return 1;
        }
    }
    for(i=0;i<14;i++){
        if(temp<pri[i]){
            if(p>m2+pri[i-1]&&p<m2+pri[i])
            printf("Thrown\n");
            else printf("0\n");
            return 1;
        }
    }
}
int main()
{
    int tcase,n,m,k;
    scanf("%d",&tcase);
    while(tcase--){
        scanf("%d%d%d",&n,&m,&k);
        solve(n,m,k);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值