字典树(Trie)hdu2846

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2487    Accepted Submission(s): 954


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
      
      
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
      
      
0 20 11 11 2


思路:把所有单词的后缀建树,每个节点保存一下有多少个但此经过,直接查询就好了。这样存在一个问题,可能存在重复计数(如:abababab的后缀ababab和abab会发生重复),因为只有同一个单词才会发生这种情况,我们可以在节点中添加一个id域记录上一次经过这个节点的是谁,如果相同就不用再记一次了。

第一次看这个题,让我想起了后缀树这东西,虽然没学过后缀树,正好看一下

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=10010;
int n;
char s[30];
struct node
{
    node *next[26];
    int id,val;
    node(){memset(next,0,sizeof(next));id=val=0;}
};
struct TRIE
{
    node *root;
    void clear(){root=new node();}
    int idx(char x){return x-'a';}
    void insert(char *s ,int id)
    {
        node *p=root;
        int n=strlen(s);
        for(int i=0;i<n;i++)
        {
            int c=idx(s[i]);
            if(!p->next[c])
                p->next[c]=new node();
            p=p->next[c];
            if(p->id!=id){p->val++;p->id=id;}
        }

    }
    int find(char *s)
    {
        node *p=root;
        int n=strlen(s);
        for(int i=0;i<n;i++)
        {
            int c=idx(s[i]);
            if(!p->next[c])return 0;
            p=p->next[c];
        }
        return p->val;
    }
}tree;
int main()
{
    scanf("%d",&n);
    tree.clear();
    for(int i=1;i<=n;i++)
    {
        scanf("%s",s);
        int len=strlen(s);
        for(int j=0;j<len;j++)
            tree.insert(s+j,i);
    }
    int q;
    scanf("%d",&q);
    while(q--)
    {
        scanf("%s",s);
        printf("%d\n",tree.find(s));
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值