HDU-2846 Repository (Trie 字典树 入门题)

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5891    Accepted Submission(s): 1954


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
  
  
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
  
  
0 20 11 11 2
 
#include <bits/stdc++.h>
using namespace std;
#define maxn 500000
int ch[maxn][27], sz[maxn], tot;
map<int, int>mp;
void insert(char s[], int j){
	int n = strlen(s), k = 0, y;
	for(int i = j; i < n; ++i){
		y = s[i] - 'a';
		if(ch[k][y] == 0){
			ch[k][y] = ++tot;
		}
		k = ch[k][y];
		if(mp[k] == 0){     //没出现过才计算个数
			sz[k]++;
			mp[k] = 1;
		}
	}
}
int query(char s[]){
	int n = strlen(s), k = 0, y;
	for(int i = 0; i < n; ++i){
		y = s[i] - 'a';
		if(ch[k][y] == 0){
			return 0;
		}
		k = ch[k][y];
	}
	return sz[k];
}
int main(){
	int n, ans = 0;
	char s[22];
	memset(sz, 0, sizeof(sz));
	tot = 0;
	scanf("%d", &n);
	for(int i = 1; i <= n; ++i){
		scanf("%s", s);
		int x = strlen(s);
		mp.clear();     
		for(int j = 0; j < x; ++j){
			insert(s, j);
		}
	}
	scanf("%d", &n);
	for(int i = 1; i <= n; ++i){
		scanf("%s", s);
		printf("%d\n", query(s));
	}
}

/*
题意:1e4个单词,每个单词长度为20。1e5次询问,回答给定单词是多少
个单词的子串。

思路:对所有原单词先建trie,每个单词的所有子串都要建进去,即
复杂度O(20*20*10000)。对于每次询问,注意一下坑点:像add这种单词,
d作为子串出现了两次,但统计答案时只能算一次,所以在插入时注意处理
这种情况,然后对于每个结点i记录一下sz[i],常规遍历询问就行了。
*/

  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值