Let Me Count The Ways

Let Me Count The Ways

After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny: 1c, nickel: 5c, dime: 10c, quarter: 25c, half-dollar: 50c) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 30000 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.

There are m ways to produce n cents change.

There is only 1 way to produce n cents change.

Sample input

17 
11
4

Sample output

There are 6 ways to produce 17 cents change. 
There are 4 ways to produce 11 cents change. 
There is only 1 way to produce 4 cents change.

题目描述:找零钱,求N元的找零方案。零钱种类有:1,5,10,25,50
分析:动态规划,每次划分为小问题来求解。
代码:
(1)

#include<iostream>
#include<cstring>

using namespace std;
int coin[5]={1,5,10,25,50};
long long v[30005][5];
int num;

int main()
{
      memset(v,0,sizeof(v));
      for(int i=0;i<5;i++)  v[0][i]=1;
     
       for(int i=1;i<=30000;i++)
      {
                for(int j=0;j<5;j++)
                {
                    if(j!=0)
                    {
                    if(coin[j]<=i)  v[i][j]=v[i-coin[j]][j]+v[i][j-1];//v[i-coin[j]][j]表示加了第j种硬币的方案数 , v[i][j-1]表示不加的方案数。 
                    //v[i][j]表示 n 元的钱,加入前 j种硬币总共有多少种方案 ,可拆分为包含第 j 种跟不包含第 j 种的方案数之和。 
                    //eg:v[100][2]=v[[90][2]+v[100][1]; 再根据v[90][2]来算 ,相当于递归。 
                    else v[i][j]+=v[i][j-1];
                   }
                   else v[i][j]=v[i-coin[j]][j];
                }
        }
        /* 
                     if(coin[j]<=i)v[i][j]=v[i-coin[j]][j];
                    if(j!=0)v[i][j]+=v[i][j-1];
              }*/
        while(cin>>num)
        {
           if(v[num][4]==1)cout<<"There is only 1 way to produce "<<num<<" cents change."<<endl;
            else cout<<"There are "<<v[num][4]<<" ways to produce "<<num<<" cents change."<<endl;
        }
        return 0;
}

(2)与(1)基本一样
#include<iostream>
#include<cstring>
using namespace std;
int coin[6]={1,5,10,25,50};
long long v[30005][5];
int num;

int main()
{
     memset(v,0,sizeof(v));
     for(int i=0;i<5;i++)  v[0][i]=1;
     
     for(int i=1;i<=30000;i++){
                for(int j=0;j<5;j++){
                     if(coin[j]<=i)v[i][j]=v[i-coin[j]][j];
                    if(j!=0)v[i][j]+=v[i][j-1];
              }
        }

  while(cin>>num){
           if(v[num][4]==1)cout<<"There is only 1 way to produce "<<num<<" cents change."<<endl;
            else cout<<"There are "<<v[num][4]<<" ways to produce "<<num<<" cents change."<<endl;
        }
        return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值