【解题报告】uva357_Let Me Count The Ways(让我来数数方案, dp, 完全背包)

16 篇文章 0 订阅
12 篇文章 0 订阅
357 - Let Me Count The WaysTime limit: 3.000 seconds Let Me Count The Ways After making a purchase at a large department store, Mel's change was 17 cents. He received 1
摘要由CSDN通过智能技术生成

357 - Let Me Count The Ways

Time limit: 3.000 seconds

 Let Me Count The Ways 

After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny: 1c, nickel: 5c, dime: 10c, quarter: 25c, half-dollar: 50c) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 30000 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.

There are m ways to produce n cents change.

There is only 1 way to produce n cents change.

Sample input

17 
11
4

Sample output

There are 6 ways to produce 17 cents change. 
There are 4 ways to produce 11 cents change. 
There is only 1 way to produce 4 cents change.


题目大意:

给出5种面值的硬币(1,5,10,25,50),每次输入一个金额(0-30000),求用所给硬币组合出该金额共有多少种组合方案,硬币的顺序不影响方案数量。


解题思路:

完全背包问题。定义状态d(i,j),代表用前i种硬币组合出金额j的方案数。

状态转移方程:d(i,j) = ∑ { d(i-1,j-k*c[i]) | 1<=k<=j/c[i], c[i]∈{1,5,10,25,50} }

结果会超int范围,用long long来存状态的结果。


#include <cstdio>

int c[5]={1,5,10,25,50};//5种面值的硬币
long long d[30001];//状态

int main()
{
    d[0]=1;
    for(int i=0;i<5;++i){//枚举5种面值硬币
        for(int j=c[i];j<=30000;++j){//枚举金额状态
            d[j]+=d[j-c[i]];
        }
    }
    int n;
    while(~scanf("%d",&n)){
        if(d[n]==1) printf("There is only 1 way to produce %d cents change.\n",n);
        else printf("There are %lld ways to produce %d cents change.\n",d[n],n);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值