hdu 题目1085 Holding Bin-Laden Captive! (母函数及其应用)

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12346    Accepted Submission(s): 5536


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
  
  
1 1 3 0 0 0
 

Sample Output
  
  
4
 


$1 的个数 n1

$2 的个数 n2

$5 的个数n5


故其母函数为:

G(x) = (1 + x+ x^2 + x^3 + ...+ x^n1) (1+x^2 + x^4 +...+ x^(2*n2) )(1+x^5 + x^10 +...+ x^(5*n5) )





/***************************
# 2013-8-26 20:14:55 
# Time: 15MS   Memory: 228KB
# Author: zyh
# Status: Accepted
***************************/ 

#include<stdio.h>

int main()
{
    int i,j,k,n1,n2,n5,c1[8010],c2[8010]; // 第一次WA数组开小了
    
    while(scanf("%d%d%d",&n1,&n2,&n5),(n1!=0||n2!=0||n5!=0))  //第三次 WA 这里条件写错了
    {
        int n = n1+2*n2+5*n5; //最高次幂
        for(i=0;i<=n;i++){ //初始化第一个括号里的表达式所能代表的$
            if(i<=n1) c1[i] = 1;
            else c1[i] = 0;
            c2[i] = 0;
        }
        
        for(j=0;j<=n1;j++) //第一个括号表达式里面项的个数
            for(k=0;j+k<=n1+n2*2;k+=2){
                c2[j+k] += c1[j];
            }

        for(j=0;j<=n;j++){
            c1[j]  = c2[j];
            c2[j] = 0;
        }
    
        for(j=0;j<=n1+2*n2;j++)  //前两个括号表达式 计算过后 里面项的个数
            for(k=0;j+k<=n;k+=5){
                c2[j+k] += c1[j];
        }
        for(j=0;j<=n;j++){
            c1[j] = c2[j];
            c2[j] = 0;
        }
        for(i=0;i<=n;i++) {     
            if(c1[i]==0){
                 printf("%d\n",i);    
                break;
            }
        }    
        if(i==n+1){  //第二次WA 这里没考虑
            printf("%d\n",i);
        }        
    }
    return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值