Holding Bin-Laden Captive! (HDU-1085)(母函数)

We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input

Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output

Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input

1 1 3
0 0 0

Sample Output

4

题意:现在你有三种面值的硬币,分别是1,2,5,然后给你这三种面值硬币各自的数量,问你无法组合的最小面值。

思路:这道题的话,就是用母函数的方法来做,公式为 (1+x+x^2+x^3+.........x^cnt1)∗(1+x^2+x^4+x^6+.........x^cnt2)∗(1+x^5+x^10+x^15+............x^cnt5)。

套一下模板即可。

AC代码1:

#include <bits/stdc++.h>
typedef long long ll;
const int maxx=10010;
const int inf=0x3f3f3f3f;
using namespace std;
struct node
{
    int val,cnt;
} num[maxx];
int sup[maxx],temp[maxx];
int main()
{
    num[0].val=1,num[1].val=2,num[2].val=5;
    while(~scanf("%d%d%d",&num[0].cnt,&num[1].cnt,&num[2].cnt),num[0].cnt,num[1].cnt,num[2].cnt)
    {
        int mav=num[0].cnt*num[0].val+num[1].cnt*num[1].val+num[2].cnt*num[2].val;
        memset(sup,0,sizeof(sup));
        memset(temp,0,sizeof(temp));
        for(int i=0; i<=num[0].cnt; i++)
        {
            sup[i]=1;
            temp[i]=0;
        }
        for(int i=1; i<3; i++)
        {
            for(int j=0; j<=mav; j++)
            {
                for(int k=0; j+k<=mav && k<=num[i].cnt*num[i].val; k+=num[i].val)
                {
                    temp[j+k]+=sup[j];
                }
            }
            for(int j=0; j<=mav; j++)
            {
                sup[j]=temp[j];
                temp[j]=0;
            }
        }
        int i;
        for(i=1; i<=mav; i++)
        {
            if(!sup[i])
                break;
        }
        printf("%d\n",i);
    }
    return 0;
}

AC代码2:

#include <bits/stdc++.h>
typedef long long ll;
const int maxx=10010;
const int inf=0x3f3f3f3f;
using namespace std;
int sup[maxx],temp[maxx];
int v[3]= {1,2,5};
int n[maxx];
int main()
{
    while(~scanf("%d%d%d",&n[0],&n[1],&n[2]),n[0],n[1],n[2])
    {
        memset(sup,0,sizeof(sup));
        sup[0]=1;
        int p=n[0]*v[0]+n[1]*v[1]+n[2]*v[2];
        for(int i=0; i<3; i++)
        {
            memset(temp,0,sizeof(temp));
            for(int j=0; j<=n[i] && j*v[i]<=p; j++)
            {
                for(int k=0; k+j*v[i]<=p; k++)
                {
                    temp[k+j*v[i]]+=sup[k];
                }
            }
            memcpy(sup,temp,sizeof(temp));
        }
        int i;
        for(i=0; i<=p; i++)
            if(!sup[i])
                break;
        printf("%d\n",i);
    }
    return 0;
}

下面基于AC代码2给出优化版本。用一个last变量记录目前最大的指数,这样只需要在0..last上进行计算。

AC代码3:

#include <bits/stdc++.h>
typedef long long ll;
const int maxx=10010;
const int inf=0x3f3f3f3f;
using namespace std;
int sup[maxx],temp[maxx];
int v[3]= {1,2,5};
int n[maxx];
int main()
{
    while(~scanf("%d%d%d",&n[0],&n[1],&n[2]),n[0],n[1],n[2])
    {
        memset(sup,0,sizeof(sup));
        sup[0]=1;
        int last=0,last2;
        for(int i=0; i<3; i++)
        {
            last2=last+n[i]*v[i];
            memset(temp,0,sizeof(int)*(last2+1));
            for(int j=0; j<=n[i] && j*v[i]<=last2; j++)
            {
                for(int k=0; k<=last && k+j*v[i]<=last2; k++)
                {
                    temp[k+j*v[i]]+=sup[k];
                }
            }
            memcpy(sup,temp,sizeof(int)*(last2+1));
            last=last2;
        }
        int i;
        for(i=0; i<=last; i++)
            if(!sup[i])
                break;
        printf("%d\n",i);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值