hdu 1085 Holding Bin-Laden Captive!(母函数)

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23120 Accepted Submission(s): 10300

Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”

Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds– 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input

1 1 3
0 0 0

Sample Output

4

Author
lcy


样例:三个数代表1,2,5硬币的个数。输出不能用这些硬币来组成的钱数。


刚开始没有想到怎么处理硬币的个数问题。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 11111
int a[3], b[3]={1,2,5};
int nm1[N], nm2[N];
int main()
{
    freopen( "in.txt", "r", stdin );
    int i, j, k, mx;
    while( scanf( "%d%d%d", &a[0], &a[1], &a[2] ) != EOF ){
        if( a[0] == 0 && a[1] == 0 && a[2] == 0 ) break;
        memset( nm1, 0, sizeof( nm1 ));
        memset( nm2, 0, sizeof( nm2 ));
        mx = 0;
        for( i = 0 ; i < 3 ; i ++ ){
            mx += a[i]*b[i];///
        }
        for( i = 0 ; i <= a[0] ; i ++ ){///从0开始,1 1 2的时候,判断到面值为2的硬币,nm2[2]=0了,会错,面值为5的同理。
            nm1[i] = 1;
        }
        for( i = 1 ; i < 3 ; i ++ ){
            for( j = 0 ; j <= mx ; j ++ ){
                if( nm1[j] )
                for( k = 0 ; k <= a[i]*b[i] ; k += b[i] ){///
                    nm2[k + j] += nm1[j];
                }
            }
            memcpy( nm1, nm2, sizeof( nm1 ));///sizeof( nm1 ) != N
            memset( nm2, 0, sizeof( nm2 ));
//            for( int t = 0 ; t <= mx ; t ++ ){
//                nm1[t] = nm2[t];
//                nm2[t] = 0;
//            }
        }
        for( i = 1 ; i < N ; i ++ ){
            if( !nm1[i] ) break;
        }
        cout<<i<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值