POJ 一 2632 Crashing Robots

Crashing Robots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6791 Accepted: 2942

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
 
Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of 
  • L: turn left 90 degrees, 
  • R: turn right 90 degrees, or 
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2
 
题意很简单,就是模拟一个地图,通过输入确定机器人的位置和移动,判断机器人移动后的状态。
难就难在数据结构的选择上,由于平时做题都是用数组,单一变量的,没有考虑到结构体,导致这个题完全没有思路。
通过 网上找的c++答案,改成C后运行错误。
通过调试发现对字符的输入使用错误。
应该用scanf(" %c")而不是scanf("%c");这样做可以过滤掉字符前的空格。
因为scanf("%c")可以读取空格!!!!切记!!!
代码的巧妙之处就在于用结构体来输入数据。
代码如下:
#include <stdio.h>
#include <string.h>
#include <stdbool.h>
#define LOCAL

struct rob
{
  int x,y,dre;
}robot[101];

struct instruction
{
  int rb_id,step;
  char point;       
}ins[101];

int map[101][101];
int a,b;

bool process(struct instruction act);

int main(void)
{    
    #ifdef LOCAL
      freopen("data.in","r",stdin);
      freopen("data.out","w",stdout);
    #endif
    
    int ncases;
    int m,n;
    char ch;
    
    scanf("%d",&ncases);
    while(ncases--)
    {
     memset(map,0,sizeof(map));
     memset(ins,0,sizeof(ins));
     
     scanf("%d%d",&a,&b);
     scanf("%d%d",&n,&m);
     int i;
     for(i=1;i<=n;i++)
     {
      scanf("%d%d",&robot[i].x,&robot[i].y);
      scanf(" %c",&ch);
      if(ch=='N')
        robot[i].dre=0;
      if(ch=='W')
        robot[i].dre=1;
      if(ch=='S')
        robot[i].dre=2;
      if(ch=='E')
        robot[i].dre=3;                  
      map[robot[i].x][robot[i].y]=i;
     }
     
     for(i=1;i<=m;i++)
     {
      scanf("%d",&ins[i].rb_id);
      scanf(" %c",&ch);
      scanf("%d",&ins[i].step); 
      if(ch=='L')
       ins[i].point=1;
      else if(ch=='R')
       ins[i].point=-1;
      else 
       ins[i].point=0;
     } //输入
     
     for(i=1;i<=m;i++)
     {
      if(!process(ins[i]))
        break;                 
     } 
     if(i>m)
      printf("OK\n");
    }
    return 0;
}

bool process(struct instruction act)
{
    int i;
    int id=act.rb_id;
    while(act.step--)
    {
     if(act.point==1)
      robot[id].dre=(robot[id].dre+1)%4; 
     else if(act.point==-1)
     {
      robot[id].dre-=1;
       if(robot[id].dre==-1)
        robot[id].dre=3;    
     }                
     else if(act.point==0)
     {
      map[robot[id].x][robot[id].y]=0;
      switch(robot[id].dre)
      {
       case 0:robot[id].y++;break;
       case 1:robot[id].x--;break;
       case 2:robot[id].y--;break;
       case 3:robot[id].x++;break;                    
      }
      if(robot[id].x<1||robot[id].y<1||robot[id].x>a||robot[id].y>b)
      {
       printf("Robot %d crashes into the wall\n",id);
       return false;
      }    
      else if(map[robot[id].x][robot[id].y])
      {
       printf("Robot %d crashes into robot %d\n",id,map[robot[id].x][robot[id].y]);
       return false;
      }
      map[robot[id].x][robot[id].y]=id;
     }
    }
    return true;
} 


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值