In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.
Input
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.
The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.
Figure 1: The starting positions of the robots in the sample warehouse
Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of
and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.
Output
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.
Figure 1: The starting positions of the robots in the sample warehouse
Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of
- L: turn left 90 degrees,
- R: turn right 90 degrees, or
- F: move forward one meter,
and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.
Output one line for each test case:
Only the first crash is to be reported.
Sample Input
- Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
- Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
- OK, if no crashing occurs.
Only the first crash is to be reported.
4 5 4 2 2 1 1 E 5 4 W 1 F 7 2 F 7 5 4 2 4 1 1 E 5 4 W 1 F 3 2 F 1 1 L 1 1 F 3 5 4 2 2 1 1 E 5 4 W 1 L 96 1 F 2 5 4 2 3 1 1 E 5 4 W 1 F 4 1 L 1 1 F 20Sample Output
Robot 1 crashes into the wall Robot 1 crashes into robot 2 OK Robot 1 crashes into robot 2题意为给定一限定长宽的地图,输入n个机器人的x、y坐标,面朝方向(N,W,S,E),机器人的位置以及面向方向可以封装在类robot或结构体robot中。输入m条指令,指令包含指向的机器人编号num,指令符号(L左转,R右转,F径直移动),执行次数t。可以通过定义类函数来实现。最终目标为,找出发生碰撞的情况,若无碰撞,则输出OK。该题用于练习C++类的封装,效果极佳。代码如下:
#include <iostream>
#include <memory.h>
#include <stdio.h>
int map[200][200];
int length,wid;
using namespace std;
class Robot{
public:
int posx,posy;
char dir;
Robot(){}
Robot(int x,int y,char dir):posx(x),posy(y),dir(dir){}
int Done(int num,char zhiling,int time);
};
int Robot::Done(int num,char zhiling,int time){
for(int i=0;i<time;i++){
switch (zhiling){
case 'L':
if(dir=='N') dir='W';
else if(dir=='W') dir='S';
else if(dir=='S') dir='E';
else if(dir=='E') dir='N';
break;
case 'R':
if(dir=='N') dir='E';
else if(dir=='W') dir='N';
else if(dir=='S') dir='W';
else if(dir=='E') dir='S';
break;
case 'F':
if(dir=='N') {
posy++;
if(posy>wid) {printf("Robot %d crashes into the wall\n",num);return 1;}
else if(map[posx][posy]!=0 && map[posx][posy]!=num) {printf("Robot %d crashes into robot %d\n",num,map[posx][posy]);return 1;}
map[posx][posy]=num;
map[posx][posy-1]=0;
}
else if(dir=='W') {
posx--;
if(posx==0) {printf("Robot %d crashes into the wall\n",num);return 1;}
else if(map[posx][posy]!=0 && map[posx][posy]!=num) {printf("Robot %d crashes into robot %d\n",num,map[posx][posy]); return 1;}
map[posx][posy]=num;
map[posx+1][posy]=0;
}
else if(dir=='S') {
posy--;
if(posy==0) {printf("Robot %d crashes into the wall\n",num);return 1;}
else if(map[posx][posy]!=0 && map[posx][posy]!=num) {printf("Robot %d crashes into robot %d\n",num,map[posx][posy]);return 1;}
map[posx][posy]=num;
map[posx][posy+1]=0;
}
else if(dir=='E') {
posx++;
if(posx>length) {printf("Robot %d crashes into the wall\n",num);return 1;}
else if(map[posx][posy]!=0 && map[posx][posy]!=num) {printf("Robot %d crashes into robot %d\n",num,map[posx][posy]);return 1;}
map[posx][posy]=num;
map[posx-1][posy]=0;
}
}
}
return 0;
}
int main(){
int T,len,wid,robotnum,ordernum,x,y,time,num;
char dir,zhiling;
cin>>T;
while(T--){
cin>>length>>wid;
memset(map,0,sizeof(map));
cin>>robotnum>>ordernum;
Robot rarray[robotnum+1];
for(int i=1;i<=robotnum;i++){
cin>>x>>y>>dir;
rarray[i]=Robot(x,y,dir);
map[x][y]=i;
}
int flag=0;
for(int j=0;j<ordernum;j++){
cin>>num>>zhiling>>time;
if(flag==0)
if( rarray[num].Done(num,zhiling,time)==1){flag=1;}
}
if(flag==0) printf("OK\n");
}
}