CEOI 2002, POJ 1038 Bugs Integrated, Inc. 状态压缩 DP

Bugs Integrated, Inc.
Time Limit: 15000MS Memory Limit: 30000K
Total Submissions: 9052 Accepted: 3458
Case Time Limit: 5000MS

Description

Bugs Integrated, Inc. is a major manufacturer of advanced memory chips. They are launching production of a new six terabyte Q-RAM chip. Each chip consists of six unit squares arranged in a form of a 2*3 rectangle. The way Q-RAM chips are made is such that one takes a rectangular plate of silicon divided into N*M unit squares. Then all squares are tested carefully and the bad ones are marked with a black marker. 

Finally, the plate of silicon is cut into memory chips. Each chip consists of 2*3 (or 3*2) unit squares. Of course, no chip can contain any bad (marked) squares. It might not be possible to cut the plate so that every good unit square is a part of some memory chip. The corporation wants to waste as little good squares as possible. Therefore they would like to know how to cut the plate to make the maximum number of chips possible. 
Task 
You are given the dimensions of several silicon plates and a list of all bad unit squares for each plate. Your task is to write a program that computes for each plate the maximum number of chips that can be cut out of the plate.

Input

The first line of the input file consists of a single integer D (1 <= D <= 5), denoting the number of silicon plates. D blocks follow, each describing one silicon plate. The first line of each block contains three integers N (1 <= N <= 150), M (1 <= M <= 10), K (0 <= K <= MN) separated by single spaces. N is the length of the plate, M is its height and K is the number of bad squares in the plate. The following K lines contain a list of bad squares. Each line consists of two integers x and y (1 <= x <= N, 1 <= y <= M) ?coordinates of one bad square (the upper left square has coordinates [1, 1], the bottom right is [N,M]).

Output

For each plate in the input file output a single line containing the maximum number of memory chips that can be cut out of the plate.

Sample Input

2
6 6 5
1 4
4 6
2 2
3 6
6 4
6 5 4
3 3
6 1
6 2
6 4

Sample Output

3
4

Source



有点点小虐心。


#include <iostream>
#include <cstring>
#include <fstream>
using namespace std;

const int ternarys[12] = { 0, 1, 3, 9, 27, 81, 243, 729, 2187, 6561, 19683, 59049 };
int DP[2][59049];
int bit_map[155][15];
int pre_line[15];
int now_line[15];

int N, M, K;


int transform_to_decimal( int* arr ){

    int res = 0;
    for( int m = 1; m <= M; ++m )
        res += arr[m] * ternarys[m];
    return res;

}


void transform_to_ternary( int val, int* arr ){
    for( int m = 1; m <= M; ++m ){
        arr[m] = val % 3;
        val /= 3;
    }
}


void dfs_search( int n, int m, int last, int state ){

    DP[n % 2][state] = max( DP[n % 2][state], last );

    if( m >= M )
        return;

    if( !pre_line[m] && !pre_line[m + 1] && !now_line[m] && !now_line[m + 1] ){
        now_line[m] = now_line[m + 1] = 2;
        int _state = transform_to_decimal( now_line );
        dfs_search( n, m + 2, last + 1, _state );
        now_line[m] = now_line[m + 1] = 0;
    }

    if( m < M - 1 && !now_line[m] && !now_line[m + 1] && !now_line[m + 2] ){
        now_line[m] = now_line[m + 1] = now_line[m + 2] = 2;
        int _state = transform_to_decimal( now_line );
        dfs_search( n, m + 3, last + 1, _state );
        now_line[m] = now_line[m + 1] = now_line[m + 2] = 0;
    }

    dfs_search( n, m + 1, last, state );

}


int main(){

    int cases;
    cin >> cases;

    while( cases-- ){

        cin >> N >> M >> K;

        for( int i = 0; i < ternarys[M + 1]; ++i )
            DP[1][i] = -1;

        memset( bit_map, 0, sizeof( bit_map ) );

        for( int k = 0; k < K; ++k ){
            int n, m;
            cin >> n >> m;
            bit_map[n][m] = 1;
        }

        for( int i = 1; i <= M; ++i )
            pre_line[i] = bit_map[1][i] + 1;

        int state = transform_to_decimal( pre_line );
        DP[1][state] = 0;

        for( int n = 2; n <= N; ++n ){

            for( int _state = 0; _state < ternarys[M + 1]; ++_state )
                DP[n % 2][_state] = -1;

            for( int _state = 0; _state < ternarys[M + 1]; ++_state ){

                if( DP[( n + 1 ) % 2][_state] == -1 )
                    continue;

                transform_to_ternary( _state, pre_line );

                for( int m = 1; m <= M; ++m ){
                    if( bit_map[n][m] )
                        now_line[m] = 2;
                    else
                        now_line[m] = max( pre_line[m] - 1, 0 );
                }

                int now_state = transform_to_decimal( now_line );

                dfs_search( n, 1, DP[( n + 1 ) % 2][_state], now_state );

            }
        }

        int res = 0;

        for( int _state = 0; _state < ternarys[M + 1]; ++_state )
            res = max( res, DP[N % 2][_state] );

        cout << res << endl;

    }

    return 0;

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值