TOJ 2861 ZOJ 1086 Octal Fractions / 大数 高精度

Octal Fractions

时间限制(普通/Java):1000MS/3000MS     运行内存限制:65536KByte

描述

Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.953125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point.

Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals.

输入

The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k.

输出

Your output will consist of a sequence of lines of the form

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]


where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

样例输入

0.75
0.0001
0.01234567

样例输出

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]

可以怎么做 0.75 = (5/8+7)/8

0.01234567 = (((7/8+6)/8)+5)/8....

模拟高精度就行

代码高队长提供

#include <stdio.h>
#include <string.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
string s;
char res[30000];
int reslen;
void js()
{
	int i,j,k,num=0;
	for(i=0;;i++)
	{
		if(res[i]!=0)
			num = num * 10 + res[i]-'0';
		else 
			num = num * 10;
		res[i]=num/8+'0';
		num=num%8;
		if(res[i+1]==0&&num==0) break;
	}
}
int main()
{
	while(cin >> s)
	{
		reverse(s.begin(),s.end());
		memset(res,0,sizeof(res));
		int i,j,k;
		for(i=0;s[i]!='.';i++)
		{
			res[0]=s[i];
			js();
		}
		reverse(s.begin(),s.end());
		cout << s <<" [8] = 0."<< res + 1 << " [10]"<<endl;
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值