TOJ 3504 Repeatless Numbers / 深搜

Repeatless Numbe

时间限制(普通/Java):1000MS/3000MS     运行内存限制:65536KByte
 

描述

Arepeatless number is a positive integer containing no repeated digits. For instance, the first 25 repeatless numbers are

1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 23, 24, 25, 26, 27, …

Given an integer n, your goal is to compute thenth repeatless number.

输入

The input test file will contain multiple test cases, each consisting of a single line containing the integern, where 1 ≤n ≤ 1000000. The end-of-file is marked by a test case withn = 0 and should not be processed.

输出

For each input case, the program should print the nth repeatless number on a single line.

样例输入

25
10000
0

样例输出

27
26057

#include <stdio.h>
int a[1000010];
int t = 0;
int map[10];
void dfs(int sum,int k,int flag)//flag=0是表示0可以无限用 flag=1表示0只能用一次 00000001 
{
	if(k == 8)
	{
		a[t++] = sum;
		return;
	}
	if(t > 1000000)
		return;
	int i;
	for(i = 0; i < 10; i++)
	{
		if(i == 0)
		{
			if(!flag)//0000000就是这种情况 前面的0可以随便用 
			{
				dfs(0,k+1,0);
			}
			else//flag=1 你们说明 比如00000010最后这个0 只能用1次 
			{
				if(!map[i])
				{
					map[i]=1;
					dfs(sum*10+i,k+1,1);
					map[i]=0;
				}
			}
		}
		else
		{
			if(!map[i])
			{
				map[i]=1;
				dfs(sum*10+i,k+1,1);
				map[i]=0;
			}
		}
	}
}
int main()
{
	dfs(0,0,0);
	int n;
	while(scanf("%d",&n),n)
	{
		printf("%d\n",a[n]);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值