hdu 1517 A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3113    Accepted Submission(s): 1785

Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either  

Stan wins.  

or  

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
  
  
162 17 34012226
 

Sample Output
  
  
Stan wins. Ollie wins. Stan wins.
 
博弈问题:
一: 2<=n<=9,第一个人赢;
二: 10<=n,第二个人赢;(因为可以取2到9这几个数,第一个人无论取哪个数都不会赢;所以,第一个人尽量取小的数字2,尽量使第二个 人不能赢,而第二个人最大取到9;因此,从10到2*9=18都是第一个人输。)
三: 18<n,(注意)第一个人只要取过之后使n/9落在10到18这个范围,那么第二个人就必输(相当于第一个人在10<=n<=18时一样),此时,n可以取到18*9;
四: 然后总结规律:第一个人输的区间为;[18^k*9+1,18^(k+1)](k>=0,k=0,1,2...)
 
#include <stdio.h> 
#include<math.h> 
#include<string.h>
#define N 50
int main() 
{ 
    int t,flag;
    __int64 n;
    while(scanf("%I64d",&n)!=-1)
    {
        t=0;
        flag=1;
        while(n>=(__int64)pow(18,t)*9+1)
        {
            if(n<=(__int64)pow(18,t+1))    
            {
                printf("Ollie wins.\n");
                flag=0;
                break;
            }
            t++;
        }
        if(flag==1)
            printf("Stan wins.\n");
    }
    return 0; 
}  

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值